Bug with kopano-dbadm and server.cfg



  • I am trying to update my distro to from 8.4.5 to 8.7.5 and am doing a script for it. In part of the script I call kopano-dbadm usmp to update the database for 4-byte UTF8. I am resetting a load of parameters in the cfg files as 8.7.x now does not specify defaults.

    MySQL (really MariaDB) runs on a non-standard port 3308 and uses a non-standard socket which I specify.

    I am finding that if I do not specify mysql_host, the kopano-dbadm fails, but if I set mysql_host = localhost in server.cfg, then it works. From the man pages the default value is localhost:

       mysql_host
           The hostname of the MySQL server to use.
    
           Default: localhost
    

    Is this a bug or have I misunderstood something.


  • Kopano

    Hi @nickh,

    @nickh said in Bug with kopano-dbadm and server.cfg:

    as 8.7.x now does not specify defaults.

    this is not really true. kopano-server has its built in default and everything that you commented out in the example configuration files already reflects the default values for these options. You can also check the cfg manpages for the services, they list the default values as well.

    @nickh said in Bug with kopano-dbadm and server.cfg:

    runs on a non-standard port 3308 and uses a non-standard

    @nickh said in Bug with kopano-dbadm and server.cfg:

    if I do not specify mysql_host, the kopano-dbadm fails, but if I set mysql_host = localhost in server.cfg, then it works

    The man page about the socket specifies:

       mysql_socket
           The socket of the MySQL server to use. This option can be used to override the default mysql socket. To use the socket, the mysql_host value must be empty or 'localhost'
    
           Default:
    

    Maybe kopano-dbadm does not follow that same logic, but requires localhost to be specified so that you can override it.



  • I am agreeing that you don’t have to specify defaults any more as they are built in. That is why mine is commented out.

    It just seems strange that kopano-server and kopano-dbadm do not recognise the same set of defaults. I would have thought it was a bug.


Log in to reply