Failed to start loolwsd



  • Dear all,

    I have installed Kopano LibreOffice Online from the repository on Devuan 9.0 (ascii), which is Debian without systemd in a privileged LXC container. Installation was without problems. Since I cannot use the systemd-start script, I tried to start loolwsd for testing purposes manually with the command inside the systemd script:

    sudo -u lool /usr/bin/loolwsd --version --o:sys_template_path=/opt/lool/systemplate --o:lo_template_path=/opt/libreoffice5.4 --o:child_root_path=/opt/lool/child-roots --o:file_server_root_path=/usr/share/libreoffice-online
    

    Unfortunately I get the following errors:

    wsd-07041-07041 12:48:17.639901 [ loolwsd ] WRN  SSL support: SSL is disabled.| wsd/LOOLWSD.cpp:748
    loolforkit version details: 5.4.2 - 5.4.2
    frk-07043-07043 12:48:19.141299 [ forkit ] FTL  Capability cap_sys_chroot is not set for the loolforkit program.| kit/ForKit.cpp:155
    frk-07043-07043 12:48:19.141482 [ forkit ] FTL  Capability cap_mknod is not set for the loolforkit program.| kit/ForKit.cpp:155
    frk-07043-07043 12:48:19.142047 [ forkit ] FTL  Capability cap_fowner is not set for the loolforkit program.| kit/ForKit.cpp:155
    FATAL: Capabilities are not set for the loolforkit program.
    Please make sure that the current partition was *not* mounted with the 'nosuid' option.
    If you are on SLES11, please set 'file_caps=1' as kernel boot option.
    
    frk-07043-07043 12:48:19.142346 [ forkit ] WRN  Waking up dead poll thread [delay_poll], started: false, finished: false| net/Socket.hpp:505
    frk-07043-07043 12:48:19.142585 [ forkit ] WRN  Waking up dead poll thread [delay_poll], started: false, finished: false| net/Socket.hpp:505
    wsd-07041-07041 12:49:09.068082 [ loolwsd ] FTL  Failed to fork child processes.| wsd/LOOLWSD.cpp:2515
    FATAL: Failed to fork child processes.
    wsd-07041-07041 12:49:09.068942 [ loolwsd ] FTL  Failed to fork child processes.| wsd/LOOLWSD.cpp:2661
    Failed to fork child processes.
    wsd-07041-07041 12:49:09.069593 [ loolwsd ] WRN  Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:505
    wsd-07041-07041 12:49:09.069804 [ loolwsd ] WRN  Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:505
    wsd-07041-07041 12:49:09.070056 [ loolwsd ] WRN  Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:505
    wsd-07041-07041 12:49:09.070233 [ loolwsd ] WRN  Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.077471 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.077730 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.077868 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.077949 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.078018 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.078089 [ loolwsd ] WRN  Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.078730 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:505
    <shutdown>-07041 12:49:09.078828 [ loolwsd ] WRN  Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:505
    

    The first line is because I have disable SSL according to the documentation. I have also confirmed that the filesystem supports suid. I have added the suggested option to grub.cfg:

    linux /boot/vmlinuz root=PARTUUID=ea0b2a87-02 rootfstype=ext4 rootwait acpi_enforce_resources=lax file_caps=1 console=tty0 console=ttyS0,115200n8 noinitrd
    

    Any idea what I can do to solve this error?


Log in to reply