only full username with domain is used in caldav and carddav



  • hello,

    i’m using z-push in combination with nextcloud and have a serious issue when i want to use the combined backend (imap and nextcloud) with caldav and cardav. my problem is that for caldav and carddav i need to modify the sources after each update because the %u variable in the Logon part of both backends are containing the full email address but my shares are only using the local part without the domain part. but for imap i need the full username with the domain part.
    so what i’m currently doing after each update i modify the Logon method in both backends for example the carddav backend from

    str_replace("%u", $username, CARDDAV_PATH)
    

    to

    str_replace("%u", Utils::GetLocalPartFromEmail($username), CARDDAV_PATH)
    

    so my question is there a better way to do it? maybe with a different option that i need to configure for each backend. Or can another variable be set in the config file in the urls so that it is no longer %u maybe instead %l for the local part, like it is already done for domainpart with %d.


  • Kopano

    Hi @BigMichi1,

    I’ve created a JIRA issue to address this: https://jira.z-hub.io/browse/ZP-1522.

    In my opinion adding another placeholder like %l to the variables would be the best solution.

    Manfred



  • thanks, looking forward to the fix



  • @BigMichi1 could you show your caldav and carddav php files, i have the same problem with nextcloud.


Log in to reply