WebApp 3.5.10 final available


  • Kopano

    This release provides the following changes:

    • Ability to select other users mailbox when settings Out of Office
      Entire store of the other user should be opened, and owner permissions on the entire store is required.
    • All email addresses from to/cc/bcc field can now be copied
    • Arrow keys now work as expected with Firefox on Ubuntu
    • Default folder is selected in rules select folder dialog
    • After adding a flag, plain text is no longer visible in search preview
    • Some umlauts no longer missing for certain emails when reply/forward in plain text editor

    The changelog can be found here

    Updating can be done through the repositories, packages can be downloaded from the portal or from the download server. For community members nightly packages are available here.

    If you have feedback, we’d like to hear it here in the forum.



  • Hi,

    I’m getting an error when I try to update

    failure: repodata/repomd.xml from webapp: [Errno 256] No more mirrors to try.
    https://serial:XXXXXXXXXXXXXXXXXX@download.kopano.io/supported/webapp:/final/RHEL_7/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
    

  • Kopano

    @madpatrick I see some repo files are missing for rpm based distros. Also for pre-final and master. I’m looking into this.



  • Hi,

    I see the same problem with SLES 12!

    Retrieving repository 'Kopano-webapp' metadata ......................................................................................................[error]
    Repository 'Kopano-webapp' is invalid.
    [Kopano-webapp|https://serial@download.kopano.io/supported/webapp:/final/SLE_12/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'Kopano-webapp' because of the above error.
    

    When will this be fixed?

    Walter


  • Kopano

    @WalterHof I will place a comment here when it’s fixed.



    • Ability to select other users mailbox when settings Out of Office
      Entire store of the other user should be opened, and owner permissions on the entire store is required.

    This is a really good new feature, thank you for implementing this!


  • Kopano

    @WalterHof @madpatrick
    The repo should be fixed now.



  • @marty When trying to update on CentOS 7 i now get this error:

    Retrieving key from https://serial:<serial>@download.kopano.io/supported/webapp:/final/RHEL_7/repodata/repomd.xml.key

    The GPG keys listed for the “Final repository for Kopano-webapp (RHEL_7)” repository are already installed but they are not correct for this package.
    Check that the correct key URLs are configured for this repository.

    Failing package is: kopano-webapp-plugin-spell-de-de-2.0.0.3-38.1.noarch
    GPG Keys are configured as: https://serial:<serial>@download.kopano.io/supported/webapp:/final/RHEL_7/repodata/repomd.xml.key

    Did i miss anything or should updating work the same way as before?


  • Kopano

    @happenpappen

    Can you clean your repo (yum clean <repo) and try again?



  • @marty Yes, i did a “yum clean all” before writing my post (sorry, should have mentioned that) and tried it right now. The message stays the same…



  • @marty

    Also getting an error

    warning: /var/cache/yum/x86_64/7/Kopano-webapp/packages/kopano-webapp-lang-3.5.10.2410-106.1.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID ec07c591: NOKEY
    Public key for kopano-webapp-lang-3.5.10.2410-106.1.noarch.rpm is not installed
    


  • @marty said in WebApp 3.5.10 final available:

    Ability to select other users mailbox when settings Out of Office
    Entire store of the other user should be opened, and owner permissions on the entire store is required.

    Thanks for this feature, but if the owner permissions (e.g. for a Univention & Kopano Admin user by default not set for all other users) are not (yet) assigned, the selection or drop-down entry for this user is displayed deceptively anyway, even an alleged takeover of an auto-reply activation, but this of course does not work.

    So you should either give Kopano Admin users automatic owner permissions for all other users and of course only display the dropdown entry in the Auto Reply GUI if all rights are available and the Auto Reply can really be activated for the respective user. Additionally you should point out to the place in the GUI that owner permissions are necessary if you want to activate Auto-Reply for other users.

    Just my 2 cents
    Robert



  • @marty said in WebApp 3.5.10 final available:

    Ability to select other users mailbox when settings Out of Office
    Entire store of the other user should be opened, and owner permissions on the entire store is required.

    I’ve now tried this feature with the Kopano admin account, opened the entire store of a user and tried to set an out of office message. Does not work, does not show the users existing out of office text and manually setting one doesn’t work either. Using webapp build from yesterday (webapp-3.5.10.2414) and also a very recent kopano-core daily build.

    This feature is completely broken and useless so far.

    Or could it be that the entire out of office functionality is broken again?
    I’ve set an Out-Of-Office message for the main account (nothing special), WebApp also claims it was enabled but no response is sent. I checked the debug log for kopano-dagent:
    [kopano-dagent|T26875] [debug ] Target user has OOF inactive

    even though webapp claims it is active.



  • I’ve updated to the latest builds available on download.kopano.io today:

    • core-8.7.82.168.308dc26-Ubuntu_18.04-amd64
    • webapp-3.5.10.2415+1357.9464bc4-Ubuntu_18.04-all

    done further tests with the Out Of Office functionality, is is completely broken.
    Even though webApp claimed it was on, dagent as written above said it was off and did nothing. However when I enabled it using the commandline:
    kopano-set-oof -u myaccount@domain.tld -m 1
    now it is on! But it still does not send mail.

    Sep 18 10:37:24 m.hostname.tld kopano-dagent[807]: Wed Sep 18 10:37:24 2019: [kopano-dagent|T1765] [debug ] Target user has OOF active
    Sep 18 10:37:24 m.hostname.tld kopano-dagent[807]: Wed Sep 18 10:37:24 2019: [kopano-dagent|T1765] [info ] Starting autoresponder for out-of-office message
    Sep 18 10:37:24 m.hostname.tld kopano-dagent[807]: Wed Sep 18 10:37:24 2019: [kopano-dagent|T1765] [debug ] Running command: “/usr/sbin/kopano-autorespond” “myaccount@domain.tld” “mail-came-from-here@gmail.com” “Abwesenheitsbenachrichtung” “myaccount@domain.tld” “/tmp/autorespond.lB2nGY”
    Sep 18 10:37:24 m.hostname.tld kopano-dagent[807]: Wed Sep 18 10:37:24 2019: [kopano-dagent|T1765] [debug ] popen("/usr/sbin/kopano-autorespond" “myaccount@domain.tld” “mail-came-from-here@gmail.com” “Abwesenheitsbenachrichtung” “myaccount@domain.tld” “/tmp/autorespond.lB2nGY”) failed: No such file or directory

    To check whether this bug is in WebApp or is this also broken in kopano-core, I tried setting the OOF manually using the command line
    kopano-set-oof -u myaccount@domain.tld -m 1 -t “Nicht im Büro” -n /tmp-oof/my-textfile-with-text.oof

    But this also doesn’t work, though with a different error message:
    Sep 18 10:53:42 m.biv.bayern kopano-dagent[807]: Wed Sep 18 10:53:42 2019: [kopano-dagent|T3809] [debug ] popen("/usr/sbin/kopano-autorespond" “myaccount@domain.tld” “mail-came-from-here@gmail.com” “Nicht im Büro” “myaccount@domain.tld” “/tmp/autorespond.U67pRQ”) failed: No child processes

    Update: the entire kopano-autorespond binary is missing. It just is no longer there in latest builds.



  • This post is deleted!

  • Kopano

    @Gerald said in WebApp 3.5.10 final available:

    Update: the entire kopano-autorespond binary is missing. It just is no longer there in latest builds.

    Dagent related Python script have been moved to the kopano-dagent-pytils package. This is a new package which you might not have installed.


  • Kopano

    @Gerald
    @PRO123

    You are correct. Currently we’re looking at the admin part to fix this behavior.



  • @marty said in WebApp 3.5.10 final available:

    KW-3196 Some umlauts no longer missing for certain emails when reply/forward in plain text editor

    Hello @marty,
    this issue seems to be not entirely fixed, yet:
    I’m still receiving html-mails, whose Umlauts get lost when replying or forwarding with plaintext-editor.

    Can’t see any obvious problems:

    Content-Type: text/html; charset=UTF-8

    <html><head></head><body><div style="font-family: Verdana;font-size: 12.0px;">Ich w&uuml;rd&#39; ja nix sagen, aber ob man der Komplexit&auml;t des Themas mit Appellen gerecht wird?<br/>Wer ein Mobiltelefon bei sich am K&ouml;rper herumtr&auml;gt, braucht &uuml;ber <br/><div/>
    

    Best regards,
    Umgfoin.


  • Kopano

    @umgfoin

    Not all umlauts were handled. A better fix will be made in: https://jira.kopano.io/browse/KW-3200



  • Hi @marty,
    yes, I read that, but even Umlaut-encodings already defined in the hashmap returned by getHTMLTranslationTable : function(tableType, quoteStyle) in HTMLParser.js were not decoded:

    e.g.: würd’
    w&uuml;rd&#39;

    438     entities['252'] = '&uuml;';		// u with diaeresis
    439  	entities['252'] = '&#252;';		// u with diaeresis
    

    […]

    619	if (quoteStyle === 'ENT_QUOTES') {
    620		entities['39'] = '&#39;';
    621	}
    

    ++umgfoin.


Log in to reply