New contacts on Z-Push 2.5.1+0-0, iPhone 8 Plus



  • I am on latest Kopano 8.7.5 / Z-Push 2.5.1+0-0 / Ubuntu 16.04

    iPhone 8 Plus client, I add new Contact, the server won’t see the new added contact.

    I tried z-push-admin -a resync -u user -d deviceid

    No changes.

    I can edit existing contacts and get the update direct no problem on both sides.

    I can create a new Contact from WebApp and see the contact created on the mobile device, but not vise versa.

    Should I rollback to previous z-push version (is this possible)? I use the apt sources for updates.

    Any insight is appreciated.

    That user has about 4070 contacts.

    Best regards,

    Marc


  • Kopano

    Hi Marc,

    did you enable WBXML level log for the user and checked the logs if the contact created on the iPhone is being sent to the server?

    Does the user have multiple contact folders? If yes, did you check that he’s creating the contact in his main contacts folder?

    Does the same happen to calendar items or tasks?

    Manfred



  • Hi Manfred, thanks for quick reply!

    I enabled WBXML.

    Interestingly it does not show anything in z-push log when I add a new test contact from the phone. It stays quiet.

    No multiple contact folders, just the main Contacts folder.

    Calendars are fine, working both ways. Tasks working as well.



  • Well well, I’ve made progress. :)

    I’ve disabled iCloud Contact sync, and now I can create new contacts, and I will see it in the log right away! (iOS v12.4.1)

    Now I wonder, if anyone else encountered this.


  • Kopano

    Hi Marc,

    do the contacts created on the iPhone also appear in webapp after you disabled Cloud Contact sync?

    Manfred



  • @JungleMarc
    i think you had icloud contacts defined as default on your iphone - after disabling the default setting went to kopano account

    you can set this in the contact settings on your iphone

    rg
    christian



  • @externa1 said in New contacts on Z-Push 2.5.1+0-0, iPhone 8 Plus:

    @JungleMarc
    i think you had icloud contacts defined as default on your iphone - after disabling the default setting went to kopano account

    you can set this in the contact settings on your iphone

    rg
    christian

    Awesome I’ll look deeper if I can make it default


Log in to reply