Z-push fatal error when connecting through VPN



  • I am trying to do some testing of Kopano/z-push/Outlook with two different servers, but which should be identical installations of Kopano 8.5.8 and z-push 2.3.9. The purpose is to test the upgrade to 8.7.x. With my local server I can connect with Outlook by Active Sync. The second server is located miles away and I use OpenVPN to connect onto its LAN. When I try to connect with a new profile in Outlook, it always fails:

    Log onto Exchange ActiveSync mail server (EAS): The server cannot be found
    

    This happens when I specify the server’s LAN IP or the FQDN which resolves to the LAN IP. I believe it can find the server because every time I try, in the z-push-error.log I get:

    [FATAL] [test] Fatal error: /usr/share/zarafa-z-push/lib/utils/utils.php:1144 - Call to undefined function mb_detect_encoding() (1)
    

    The installations should be the same. Both systems are running ClearOS 7.6 (a Centos derivitive). Both systems use self-signed certs.

    I am struggling to see why I can connect to the local server and not the one by OpenVPN


  • Kopano

    @nickh you’re missing the mbstring php module.

    The path to your z-push installation indicates that your are not using our rpm packaging for z-push. Using our packages relieves your from the task to manually enable dependencies.



  • I found another thread earlier and had installed mbstring. I guess now I have to find out how to enable it. Presumably something else on the other server had sorted that before I installed Kopano.

    /etc/php.d contains an mbstring.ini file with the following in it:

    ; Enable mbstring extension module
    extension=mbstring.so
    

    I have restarted kopano. Can you tell me what else I might have to do to enable it?

    FWIW, ClearOS also uses a sandboxed version of PHP for its webconfig. That similarly appears to have mbstring enabled the same way.


  • Kopano

    Hi nickh,

    you also have to restart the webserver after adding a new php extension (or php-fpm if you’re using it).

    Manfred



  • Thanks for that. A restart of httpd did it … followed by installing php-soap and another httpd restart.

    I’ll have to find out from the package builder what happened to the dependencies.


Log in to reply