Out of Office Message: change language of Subject



  • Hi all,

    for some reason the OutofOffice message are sent with Subject “Out of Office (SubjectOfReceivedMail)” instead of something more appropriate like “Abwesenheitsnotiz (SubjectOfReceivedMail)” even though I changed /etc/sysconfig/kopano to:

    ## Path:        Network/Mail/Kopano
    ## Description: Kopano service locale
    ## Type:        string
    ## Default:     "C"
    #
    # Locale setting for all Kopano services
    #
    KOPANO_LOCALE="de_DE.UTF-8"
    
    #
    # Locale setting for Kopano userscripts
    #
    KOPANO_USERSCRIPT_LOCALE="de_DE.UTF-8"
    

    I checked the kopano-autorespond script and it is receiving the Subject line as $3 parameter. I didn’t see any Subject related config parameters in /etc/kopano/autorespond and didn’t find any docu if there theoretically are more possible config parameters for that file that are not in the default one shipped with the official repositories.

    Am I missing some language related configs somewhere, or can the Subject not be changed?

    kind regards

    Remo



  • Hi remo.

    How do you set the out of office message?

    You can set a subject trough the webapp settings.

    If you are using the kopano-set-oof command line tool you can use the -t option for an subject.

    But if your question is “How can i change the subject from oof messages on the server-side so every user has the same subject” we have to dig deeper.

    I tested an oof message and didn’t configure a subject in the setting. I got a “Abwesend (SubjectOfReceivedMail)” back.
    Maybe it comes from the webapp language?
    Can you post the /etc/kopano/webapp/config.php and the output from locale?

    Cheers
    Basti



  • Hello.

    I just tried some things.

    If i have set the english language in the webapp settings i get an “Out of Office” Subject.
    But if i choose the german language i get the “Abwesend” Subject.

    In both cases the subject was set and i had to remove it in the settings. So the field with the subject must be emptied.

    Hope that helps.

    Cheers
    Basti



  • @sebschremser

    Thank you kindly. You are right, if one is using the webapp, one can indeed change the Subject/Betreff of the message. Never tried as we are trying to not have Users use webapp/deskapp but stay with Outlook.

    I was using the Kopano Tab in Outlook OutOfOffice Button and in the Window that opens, there is no Subject Line field to be set :-(

    Maybe that should get added? Seems it was forgotten.



  • Hello.

    I don’t use Outlook so i don’t know.

    But you can try to set the default language to german in the config.php.
    Maybe the autoresponder uses the default fallback language of the webapp?

    Cheers
    Basti



  • Hello @RemoStrotkamp ,

    in my case, kopano remembers the last subject that was used.
    So if you change the oof message once via kopano-set-oof -u <user> -m 1 -t “<subject>” it will activate and deactivate the message with the static subject.

    Not a solution i know, but a temporary workaround.

    Coffee_is_Life



  • @sebschremser said in Out of Office Message: change language of Subject:

    ybe the autoresponder uses the default fallback language of the webapp?

    Thank you!

    Changed the default language in both webapp config as well as apache config but didn’t help for my account.

    Thought might be because I had already set it once. So tried with an account I was pretty sure had never used it and it chose ‘Abwesend’. So I guess at least our users who have never set it will be fine.

    Would still be neat to have Subject line field in the Outlook version of the ooof config :-)



  • Hello @RemoStrotkamp,

    i’ve found something thats related (maybe).

    run “locale -a |grep “de_DE”” on your system. my installed language is “de_DE.utf8” - not “de_DE.UTF-8”.

    Maybe this is just a naming problem.

    i remember the same issue in ZCP 7.2.4 - after upgrade all new inboxes where “Inbox” instead of “Posteingang” - Changed the value to “de_DE.UTF-8” (because it was written in the guide) - But it didnt work. - After using the system-named locale “de_DE.utf8” everything works.

    Coffee_is_life


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.