kopano-set-oof not working (Out of office notification)



  • Hi,

    we tried to use the “kopano-set-oof” command, but got the following error:

    root@office:/home/ce# kopano-set-oof --user rk --mode 1 --subject ‘Abwesenheit’ --message oof.txt
    Out of office enabled for user ‘rk’
    Setting new subject ‘Abwesenheit’ for user ‘rk’
    Unable to set out of office subject for user ‘rk’
    Current subject: No subject set
    Setting new out of office message for user ‘rk’
    Unable to set out of office message.

    The autoresponder works, but only sends an empty email without subject and body text.

    We are using:
    Kopano-Core: 8.7.80

    Appreciate your help, regards
    CE


  • Kopano

    @CE said in kopano-set-oof not working (Out of office notification):

    8.7.80

    can you try updating to the latest available version and report back if the problem then still exists?



  • We are on the stable upgrade repo:

    https://serial:XXXXXXXXXXXXXXXXXX@download.kopano.io/supported/core:/final/Debian_9.0/

    If I do an apt-get update; apt-get upgrade, the core will not upgrade, because the latest version is installed …

    Regards,
    CE


  • Kopano

    @CE you may have our supported repo configured, but since you installed a nightly version first this one has a higher version number and therefore you don’t get updates out of this repository.

    I would recommend to get in touch with our support to check how to best “downgrade” your installation to an official release.



  • i suggest, run apt-get dist-upgrade and show what it wants todo.



  • @fbartels Thanks, will do that. Is this error fixed in the current stable version? I’am a little bit confused with the versioning between the community and the stable versions.



  • @fbartels I can confirm that the issue is fixed in version core: 8.7.3



  • I have setup a new test system with kopano version 8.7.3 from supported repos. Then I reimported attachments and database.

    Now I get the following error:

    Jul 8 23:15:37 office kopano-server[2527]: Starting kopano-server version 8.7.3 (pid 2527 uid 999)
    Jul 8 23:15:37 office kopano-server[2527]: Connection to database ‘kopano’ succeeded
    Jul 8 23:15:37 office kopano-server[2527]: WARNING: Database version (8,7,80,0,118) is newer than the server version (8,7,3,0,118)
    Jul 8 23:15:37 office kopano-server[2527]: You can force the server to start with --ignore-database-version-conflict
    Jul 8 23:15:37 office kopano-server[2527]: Warning, you can lose data! If you don’t know what you’re doing, you shouldn’t be using this option!
    Jul 8 23:15:37 office kopano-server[2527]: An error occurred: version mismatch (0x80000021). Please check logfile syslog:- for details.
    Jul 8 23:15:37 office kopano-server[2527]: Waiting for mysql_server_end
    Jul 8 23:15:37 office kopano-server[2527]: Waiting for mysql_library_end
    Jul 8 23:15:37 office kopano-server[2527]: Server shutdown complete.

    If I use the --ignore-database-version-conflict switch the server starts up, but webapp is not loading and gives me further errors:

    [Mon Jul 08 23:12:27.866474 2019] [:error] [pid 634] [client 192.168.0.128:51322] MAPIException: MAPI error in /usr/share/kopano-webapp/server/includes/core/class.mapisession.php:581\nStack trace:\n#0 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(581): mapi_openmsgstore(Resource id #1, ‘\x00\x00\x00\x008\xA1\xBB\x10\x05\xE5\x10\x1A\xA1\xBB\x08…’)\n#1 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(483): MAPISession->openMessageStore(’\x00\x00\x00\x008\xA1\xBB\x10\x05\xE5\x10\x1A\xA1\xBB\x08…’, ‘Default store’)\n#2 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(116): MAPISession->getDefaultMessageStore()\n#3 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(357): MAPISession->getUser()\n#4 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(366): MAPISession->getDisabledFeatures()\n#5 /usr/share/kopano-webapp/index.php(203): MAPISession->isWebappDisableAsFeature()\n#6 {main}

    [Mon Jul 08 23:12:32.888786 2019] [:error] [pid 634] [client 192.168.0.128:51322] PHP Fatal error: Uncaught MAPIException: MAPI error in /usr/share/kopano-webapp/server/includes/core/class.mapisession.php:120\nStack trace:\n#0 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(120): mapi_ab_openentry(Resource id #6, ‘’)\n#1 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(357): MAPISession->getUser()\n#2 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(366): MAPISession->getDisabledFeatures()\n#3 /usr/share/kopano-webapp/index.php(203): MAPISession->isWebappDisableAsFeature()\n#4 {main}\n thrown in /usr/share/kopano-webapp/server/includes/core/class.mapisession.php on line 120

    How can I safely downgrade DB-Version (8,7,80,0,118) to (8,7,3,0,118)? I think this question is also interesting for all people who try to switch from community to the paid version.

    Appreciate your help …
    CE


  • Kopano

    @CE said in kopano-set-oof not working (Out of office notification):

    I can confirm that the issue is fixed in version core: 8.7.3

    Good to hear. I was sure that we fixed something in some 8.7.x for this, but did not make any recent test with it therefore I did not want to confirm before.

    @CE said in kopano-set-oof not working (Out of office notification):

    How can I safely downgrade DB-Version (8,7,80,0,118) to (8,7,3,0,118)?

    This is exactly why I have asked you before to get in contact with our support so that they can assist you with the downgrade. This is after all what you pay your subscription for.



  • Hello Forum,

    long time since i was active in this forum, but i got the same error described here and i got some informations:

    first of all, im using Kopano-server 8.7.3.0-3.1, lates build, updated on last saturday.
    im using the kopano-set-oof script to set all kinds of oof-messages.
    tried this today and it failed.

    /bin/kopano-set-oof:282: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
      if oldmsg == msg:
    Setting new out of office message for user 'my_user'  // user masked here
    Unable to set out of office message.
    
    

    i looked into line 282 and the comparison failed, caused by unicode/utf-8 comparison.
    further i quoted the if-statement and went straigt for the actual SetProps:

                try:
                  ##  here i deleted the if statement and his else-segment
                   print("Setting new out of office message for user '%s'" % username)
                   st.SetProps([SPropValue(PR_EC_OUTOFOFFICE_MSG_W, msg)])
                except:
                   print("Unable to set out of office message.")
    
    

    the error no shown:

    Traceback (most recent call last):
      File "/bin/kopano-set-oof", line 290, in <module>
        sys.exit(main())
      File "/bin/kopano-set-oof", line 283, in main
        st.SetProps([SPropValue(PR_EC_OUTOFOFFICE_MSG_W, msg)])
      File "/usr/lib/python2.7/site-packages/MAPICore.py", line 290, in SetProps
        def SetProps(self, *args): return _MAPICore.IMAPIProp_SetProps(self, *args)
    TypeError: bad argument type for built-in operation
    

    the properties from file (msg):

    /tmp/abwesenheit/<myuser>.txt: UTF-8 Unicode text
                                 : text/plain; charset=utf-8
    

    since im not that deep into python, maybe someone know how to fix this…
    or is this caused by python2.7<>python3?
    i caught some posts about migration to python3 on some systems.

    best regards
    Coffee_is_life


Log in to reply