[warning] SQL [00000044] info: Try to reconnect


  • Hello Community,

    does anyone know what is causing this warning?

    mysql errorlog is empty, and there are no tasks stopping mysql.

    I could not reproduce what is actually triggering the warning,
    and also I could not find any problems because of it.

    Platform:
    ubuntu 18.04 amd64
    kopano-server 8.7.81.138.d6c70dcba-0+242.1 amd64
    mariadb-server 1:10.1.38-0ubuntu0.18.04.2

    mariadb.cnf:
    innodb_log_file_size = 512M
    innodb_log_buffer_size = 32M
    max_allowed_packet = 32M

    Thanks in advance


  • @Chris2

    perhaps the database was down at that time?


  • @mcostan

    Thank you for this hint, but database-server was not touched and online.

    Is there anyone with a comparable setup, not faceing this warning?

    Thanks in advance


  • @Chris2

    Every time I had that message it meant that the database was unavailable…

  • Kopano

    @Chris2 this error message as in the past discussed in https://forum.kopano.io/topic/1189/server-log-warning-sql-00011047-info-try-to-reconnect-german-umlauts (which also gives some indicators on settings to adjust)


  • Here’s some gravedigging for that issue ;)

    There’s also the default timeout where mysql / mariadb just closes the connection.
    The default timeout is 8 hours.

    In my case, it happend like once per day (don’t receive much mail by night):

    2020-09-04T17:23:59.183721: [warning] SQL [00000090] info: MySQL server has gone away. Reconnecting.
    2020-09-05T11:39:32.273025: [warning] SQL [00001879] info: MySQL server has gone away. Reconnecting.
    2020-09-06T07:58:08.715451: [warning] SQL [00000045] info: MySQL server has gone away. Reconnecting.
    2020-09-06T13:04:17.721408: [warning] SQL [00000141] info: MySQL server has gone away. Reconnecting.
    2020-09-07T07:52:11.653321: [warning] SQL [00000223] info: MySQL server has gone away. Reconnecting.
    2020-09-07T08:42:28.721501: [warning] SQL [00000333] info: MySQL server has gone away. Reconnecting.
    

    Solution came from the MariaDB manual: increase the default timeout to something that is never reached.
    In my case:

    [mysqld]
    wait_timeout = 288000
    

    Other scenarios include max_packet_size or innodb_log_file_size (search for them in the forum).