Z-Push Error Ubuntu 18.04



  • Hallo,
    i can not Z-Push get to work.

    The following message will appear when i log in to xyz/Microsoft-Server-ActiveSync

    /usr/share/z-push/lib/core/zpush.php , will exist and the rights seems to be ok .

    Can someone help me ?


    Z-Push - Open Source ActiveSync
    Version 2.3.8-2ubuntu1
    FatalMisconfigurationException

    No Backend provider can be found. Check your installation and/or configuration!

    Trace:
    Array
    (
    [0] => Array
    (
    [file] => /usr/share/z-push/lib/core/zpush.php
    [line] => 410
    [function] => GetBackend
    [class] => ZPush
    [type] => ::
    [args] => Array
    (
    )

        )
    
    [1] => Array
        (
            [file] => /usr/share/z-push/lib/core/zpush.php
            [line] => 395
            [function] => GetStateMachine
            [class] => ZPush
            [type] => ::
            [args] => Array
                (
                )
    
        )
    
    [2] => Array
        (
            [file] => /usr/share/z-push/index.php
            [line] => 58
            [function] => CheckAdvancedConfig
            [class] => ZPush
            [type] => ::
            [args] => Array
                (
                )
    
        )
    

    )


  • Kopano

    Hi @eddy06,

    @eddy06 said in Z-Push Error Ubuntu 18.04:

    Version 2.3.8-2ubuntu1

    This version is quite old. I’d recommend to use the official z-push packages instead.



  • Hi,
    thank you i made an upgrade to 2.5

    In my browser i get :

    Z-Push - Open Source ActiveSync
    Version 2.5.0+0-0
    GET not supported
    This is the Z-Push location and can only be accessed by Microsoft ActiveSync-capable devices

    More information about Z-Push can be found at:
    Z-Push homepage
    Z-Push download page
    Z-Push Bugtracker
    Z-Push Wiki and Roadmap

    All modifications to this sourcecode must be published and returned to the community.
    Please see AGPLv3 License for details.

    But ether outlook 2016 or Iphone 5s wont work (syncronice)

    Can you please help me again ?

    Greetings


  • Kopano

    @eddy06 the message when visiting with a browser is normal and usually indicates that z-push should work. Please provide some logging: https://wiki.z-hub.io/display/ZP/Debugging



  • Hallo,
    sory for my late reply.

    Hmm, on android it seems to work.
    I will send the protokoll later on.

    But one more problem will exist, when i tri to connect the server with
    Zarafa Outlook Client 7.2.6.52189 (which usually work) nothing will happend
    I get an Connection error.

    How can i check this ?
    is there a log file , or can i check the port with telnet ?

    Greetings
    Markus


  • Kopano

    @eddy06 said in Z-Push Error Ubuntu 18.04:

    nothing will happend
    I get an Connection error.

    these are two very contrary statements. Anyways since this has nothing to do with your initial question I would recommend to open a dedicated topic for it. Please also provide some more information about you setup (versions etc) when doing so.

    Additionally please be aware that the old Zarafa client is unsupported for quite a while now. (but it should still connect at least)


Log in to reply