K-1540: Unable to get server list: server list



  • Hello Community,

    can someone maybe give me a short hint,
    which list is meant here, and how to configure it correct,
    so that this error does not show up anymore in server.log?

    Thanks in advance


  • Kopano

    Hi Chris2, can you share a bit more about your environment? Which version(s) are you running, and on which Linux distribution? Are you in a multi-server and/or multi-tenant environment?



  • Hi Bob, thank you for your answer, of course, here is the setup:
    running on Ubuntu 18.04.2 LTS GNU/Linux 4.15.0-47-generic x86_64
    Kopano:
    core-8.7.81.48-Ubuntu_18.04-amd64
    webapp-3.5.7.2298+1289-Ubuntu_18.04-all
    It is one single server configured with multi-tenants. (only testing)

    If you need any further informations, please let me know

    Thanks in advance


  • Kopano

    Hi Chris2, thanks for the update - I quickly discussed with the development team and we’re wondering what user backend you have configured. It looks like this is the DB backend or even the Unix backend?

    This message should not occur when you are using LDAP as a backend for your multi server/tenant setup…



  • Thank you for discussing this issue.
    That is correct i am using DB user backend, with multi tenant but single server setup.
    Is this basically wrong, or is there just one prameter set wrong, perhaps set for a LDAP setup, and now causing this error in the log?

    Thanks in advance



  • The message is corrected in 8.7.3.26.



  • That is true, message has changed since the last update:
    [warning] K-1540: Unable to get server list: Multi-server not implemented by db userplugin, getServers not implemented

    I just do not know, why it trys to use multi-server functions,
    i removed the "server_name = " option in server.cfg, it was previously set,
    but is only needed in multi-server setup, for my understanding.

    Or maybe someone else had the same problem, and knows why “getServers” is triggered.
    By the way, it seems to be used in a scheduled task, as it always shows up in log at:
    Mon Jun 3 01:00:02 2019
    Thu Jun 6 01:00:01 2019

    Thanks in advance



  • @Chris2 said in K-1540: Unable to get server list: server list:

    I just do not know, why it trys to use multi-server functions,

    Because you have enable_distributed_kopano set to yes.


Log in to reply