Z-Push 2.5 error with Mobile Phone, OK with Outlook



  • Hi,

    I am having trouble on one server with Kopano 8.7.81-48 and Z-Push 2.5.0.
    Microsoft Outlook 2019 syncs fine with EAS. Mobile Phones with Android do not.

    I have tested a Samung Galaxy 8 and a Huawei Mate 20.

    In the logs of z-push I see following entries:

    When using Outlook:
    devType=‘Outlook’ devID=‘f04958cd394f94021’ getUser=‘Username’ method=‘POST’ httpcode=‘200’

    When using the mobile phones:
    devType=’’ devID=’’ getUser=‘Username’ method=‘GET’ httpcode=‘200’

    The mobile phones are somehow using the method ‘GET’. This leads z-push to answer with “GET not supported”.

    I have double checked all settings for z-push that seemed relevant but have no idea anymore where to look and why the mobile phones use the GET method instead of POST. The same phones can connect without problems to a different server with an older version of kopano and z-push.

    Has anybody had this problem also and could point me in the right direction where to fix this?

    System is debian 9.9
    Kopano 8.7.81-48
    z-push 2.5.0

    Outlook can sync with Kopano and sending and receiving mails works.
    Webapp and Deskapp also work without problem.

    Tia

    Frank Kroeger


  • Kopano

    Hi Frank,

    did you install Z-Push from the repositories? Are you using a self-signed or an official certificate? Are you using autodiscover or did you configure account’s settings manually? Are there any errors in apache logs?

    Please enable the logging for the user and post the log of the device here. More information on how to do this is available here: https://wiki.z-hub.io/display/ZP/Debugging

    Manfred



  • Hi Manfred,

    I have installed z-push from the repositories. At the moment I have installed 2.3.9 from tarball to see if this changes anything. But the error remains.

    The server is using a let’s encrypt certificate. Apache error log doesn’t log any information during connection test.

    I have configured the account settings manually- Autodiscovery doesn’t change anything.

    Here’s the excerpt fom z-push.log after enabling wbxml logging:

    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] -------- Start
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] cmd=’’ devType=’’ devId=’’ getUser=‘xxxusernamexxx’ from=‘109.91.196.223’ version=‘2.3.9’ method=‘GET’
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] Used timezone ‘Europe/Berlin’
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] Including backend file: ‘/usr/share/z-push/backend/kopano/kopano.php’
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] BackendKopano using PHP-MAPI version: 8.7.81 - PHP version: 7.0.33-0+deb9u3
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] Request::ProcessHeaders() ASVersion: 14.0
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] ZPush::CommandNeedsAuthentication(0): true
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] KopanoBackend->Logon(): Trying to authenticate user ‘xxxusernamexxx’…
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] KopanoBackend->openMessageStore(‘xxxusernamexxx’): Found ‘DEFAULT’ store: ‘Resource id #17’
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] KopanoBackend->Logon(): User ‘xxxusernamexxx’ is authenticated
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] Store supports properties containing Unicode characters.
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] NoPostRequestException: This is the Z-Push location and can only be accessed by Microsoft ActiveSync-capable devices - code: 2 - file: /usr/share/z-push/index.php:90
    27/05/2019 23:57:25 [ 2650] [ INFO] [xxxusernamexxx] User-agent: ‘Android/8.1.0-EAS-2.0’
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] ZPush::PrintZPushLegal()
    27/05/2019 23:57:25 [ 2650] [ INFO] [xxxusernamexxx] cmd=’’ memory=‘1.58 MiB/2.00 MiB’ time=‘0.01s’ devType=’’ devId=’’ getUser=‘xxxusernamexxx’ from=‘109.91.196.223’ idle=‘0s’ version=‘2.3.9’ method=‘GET’ httpcode=‘200’
    27/05/2019 23:57:25 [ 2650] [DEBUG] [xxxusernamexxx] -------- End

    bye,
    Frank


  • Kopano

    Hi Frank,

    please also post your apache configuration for Z-Push.

    Are you using the default android mail client or some 3rd party app? Have you tried re-creating profile on the mobile device?

    Do the devices access the Z-Push server directly or is there some proxy/load balancer in front of it? What apache mods are enabled? Is PHP running as apache mod?

    Manfred



  • Hi Manfred,

    I checked the apache config and found my mistake.
    I forgot the index.php part in the alias configuration.

    In my config I originally put:

    Alias /Microsoft-Server-ActiveSync /usr/share/z-push

    after changing it to:

    Alias /Microsoft-Server-ActiveSync /usr/share/z-push/index.php

    I can finally connect the phones.
    Thank you very much for your time and help.

    Frank


  • Kopano

    @fkroeger said in Z-Push 2.5 error with Mobile Phone, OK with Outlook:

    I checked the apache config and found my mistake.

    Just FYI: the package repository also provides packages with configuration for Apache and Nginx.


Log in to reply