latest kopano build breaks z-push functionality



  • Hi all,

    The latest build breaks z-push. When we try to sync a mobile we get the following in the log:

    17/05/2019 12:44:55 [  365] [ERROR] [marcel] KopanoBackend->Logon(): login failed with error code: 0xFFFFFFFF80040115
    17/05/2019 12:44:55 [  365] [ INFO] [marcel] ServiceUnavailableException: Error connecting to KC (login) - code: 0 - file: /usr/share/z-push/backend/kopano/kopano.php:184
    17/05/2019 12:44:55 [  365] [ INFO] [marcel] User-agent: 'Apple-iPad7C5/1605.227'
    17/05/2019 12:44:55 [  365] [FATAL] [marcel] Exception: (ServiceUnavailableException) - Error connecting to KC (login)
    17/05/2019 12:44:55 [  365] [DEBUG] [marcel] LoopDetection->ProcessLoopDetectionTerminate()
    17/05/2019 12:44:55 [  365] [ INFO] [marcel] cmd='Ping' memory='1.96 MiB/4.00 MiB' time='0.01s' devType='iPad' devId='21hpngbf1l3qb9ggamidada4f4' getUser='marcel' from='84.31.90.196' idle='0s' version='2.5.0+0-0' method='POST' httpcode='503'
    1
    

    Z-push version 2.5.0+0-0 500
    Debian 9
    Kopano-server 8.7.81.32.d84d89fd9-0+229.1

    17/05/2019 13:11:04 [  366] [WARN] [marcel] /usr/share/z-push/backend/kopano/kopano.php:168 mapi_logon_zarafa(): Unable to setup service for provider (2)
    17/05/2019 13:11:04 [  366] [ERROR] [marcel] KopanoBackend->Logon(): login failed with error code: 0xFFFFFFFF80040115
    17/05/2019 13:11:04 [  366] [FATAL] [marcel] Exception: (ServiceUnavailableException) - Error connecting to KC (login)
    
    

  • Kopano

    Hi ckruijntjens,

    is it the same for all mobile users? Did you restart the services after the update? Are the users able to login into webapp?

    Manfred



  • @Manfred

    Hi Manfred. Yes login to webapp is working. All is working except z-push. When i go to the page https://domain.com/Microsoft-Server-ActiveSync it ask me to login and after that i get a blank page with the errors in the log that is shown above.

    Its for al devices the same.

    PS i restarted the services and also restarted the machine


  • Kopano

    Hi ckruijntjens,

    are there any errors in apache log? In server.log of kopano?

    Manfred



  • @Manfred Hi Manfred

    No no errors at all. this mornig my zpush was woring. after upgrading kopano the problems started with zpush


  • Kopano

    Hi ckruijntjens,

    is logging enabled in server.cfg of Kopano? What is the setting of server_listen_tls in server.cfg of Kopano?

    Edit: I’ve just setup a new debian 9 system with exactly the same KC and Z-Push versions and I’m able to login.

    Manfred



  • @Manfred

    Hi manfred that setting is disabled on my server.cfg. Could there be something wrong with the packages? Let me tell you how i upgrade my system. I created a local repository. Every night i download the latest version of kopano and then i do a sync to my zpush server with these packages. (Also a local repository) the i simply do apt-get update && apt-get upgrade. Could there be something wrong here?


  • Kopano

    Hi ckruijntjens,

    yes, logging in server.cfg is disabled per default. You have to enable that.

    You could try to changes sources to point to the official Kopano repository and re-install packages.

    Manfred



  • @Manfred

    What packages are needed for zpush. Maybe i can check these first


  • Kopano

    Hi ckruijntjens,

    apt show packagename
    

    shows the dependencies for packagename. Z-Push depends on php7-mapi or php5-mapi which come from Kopano repositories. Of course they have their own dependencies from other packages in Kopano repository which you have to check.

    Manfred



  • @Manfred

    All of this is installed i dont get it. Before the upgrade there where no problems. I will look if i can revert back to the previous version and see if it works again



  • @Manfred

    hi manfred i dig in some furher and it has nothing to do with my z-push server. i put back the old server with apache and have the same thing. it has to do with the kopano server but what could it be?



  • @Manfred

    hi manfred i did the following:

    i restored a snapshot when it was working. and it releay is working. When i login i get the zpush page and that get is not supported. However when i upgrade the kopano server and restart the serviceses i get after the login prompt a page 503 not found error. The wbapp application is working as expected.

    @fbartels Maybe this has to go out of the zpush category, because its not zpush related i believe.



  • @Manfred

    i think i am missing a new depency. if i upgrade now it works but packages are held back by debian.

    The following packages were automatically installed and are no longer required:
      libfann2 libluajit-5.1-2 libluajit-5.1-common
    Use 'apt autoremove' to remove them.
    The following packages have been kept back:
      kopano-client kopano-contacts kopano-dagent kopano-gateway kopano-ical
      kopano-monitor kopano-python-utils kopano-search kopano-server kopano-spooler
      kopano-utils libkcinetmapi0 libkcpyplug0 libkcserver0 libkcsoap0 php7-mapi
      python3-kopano python3-kopano-search python3-kopano-utils python3-mapi
    0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
    

    If i force the upgrade it breaks.



  • @Manfred

    and a litle bit furthe again. After these package upgrades it breaks:

    root@mail:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
      libfann2 libgsoap-kopano-2.8.83 libluajit-5.1-2 libluajit-5.1-common
    Use 'apt autoremove' to remove them.
    The following packages have been kept back:
      libkcinetmapi0
    The following packages will be upgraded:
      kopano-search kopano-server libkcserver0 libkcsoap0 python3-kopano
      python3-kopano-search python3-kopano-utils
    7 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    Need to get 0 B/1,263 kB of archives.
    After this operation, 3,072 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    


  • @Manfred

    Hi am i doing something wrong?


  • Kopano

    @ckruijntjens said in latest kopano build breaks z-push functionality:

    After these package upgrades it breaks

    What exactly do you mean with “breaks”? The message about kept back packages? Apt only updates packages when running an upgrade. To also get new/changed dependencies in you need to run full-upgrade.



  • @fbartels

    hi i have done this, but after this step mobile sync is not working anymore. so all is fine until the last step

    The following packages will be upgraded:
    kopano-search kopano-server libkcserver0 libkcsoap0 python3-kopano
    python3-kopano-search python3-kopano-utils

    When these above packages are upgraded i get a blank page after login.(503) if i restore my backup before the update everything is working again as it should.


  • Kopano

    @ckruijntjens said in latest kopano build breaks z-push functionality:

    8.7.81.32.d84d89fd9-0+229.1

    ah, this is the build with the new gsoap. if you check on your server with netstat on which ports kopano-server is listening you will notice that it currently only listens on ipv6, while z-push want to talk to it through ipv4.

    https://jira.kopano.io/browse/KC-1501



  • @fbartels

    a thank you for your reply and indeed this is the problem. How can i make it that kopano listens on ipv4 again?


Log in to reply