How to upgrade Kopano Community Version on UCS 4.2.5 to 4.3.x



  • Hi
    I am running Kopano 8.4.5.0-1 on UCS 4.2-5 errate534 with WebApp 3.3.0.610, LetsEncrypt 1.1.2-8 and Z-Push 2.3.7

    I tried to upgrade to UCS 4.3 by following the Wiki as described. The upgrade stops with an error when trying to connect to the Kopano repo. I guess the Step 2 in the Wiki with the command "
    ucr get kopano/repo/password)@download.kopano.io/supported/core:/final/Univention_4.3/" is trying to load the supported version of Kopano which I cannot access…
    So what to do? Any hint?
    Thx


  • Kopano

    Hi @tvdonop,

    the instructions on the linked page are only relevant when you have (or had in the past) updated the Kopano packages from our repositories (which mean you will have access to the repo that you say you currently do not have access to).

    If you have not updated Kopano from our repositories, you can simply update Univention from their web ui.



  • I installed Kopano with UCS and did an Update from UCS 4.1. to 4.2x through the UCS UI. Now trying to upgrade to UCS 4.3x will not work and create an error

    ERROR: An external repository for the Kopano Apps is currently configured.
           There are known issues when updating to UCS 4.3 and using software
           from the Kopano software repository.
           The update in the current package state is blocked.
           To update UCS, update the system according to instructions
           from the Kopano4UCS integration website and restart the update.
           https://wiki.z-hub.io/x/GgB3AQ
    Error: Update aborted by pre-update script of release 4.3-0
    Error: Please check "/var/log/univention/updater.log" for details.
    

    I followed the WIKI instructions with the result described above…

    Thx for your support and help


  • Kopano

    @tvdonop If you never possessed a Kopano subscription you can simply deactivate the repository and update from the Univention UI.



  • Thx - this worked. For whatever reason a number of Kopano repos where enabled…


Log in to reply