Installation of Kopano Core on CentOS 7 not possible



  • Hello there

    Have a fresh install of a CentOS 7 and did the following:
    yum update
    yum install epel-release
    yum install wget
    wget h t t p s://rpms.remirepo.net/enterprise/remi-release-7.rpm
    rpm -Uvh remi-release-7.rpm

    I just downloaded and unpacked: h t t p s://download.kopano.io/community/core:/core-8.7.80.936-RHEL_7_EPEL_7-x86_64.tar.gz

    Tried installing as mentioned: h t t p s://documentation.kopano.io/kopanocore_administrator_manual/installing.html#rpm-based-distributions

    In fact I did this: yum localinstall ./kopano-server-*
    This returns with 23 dependency errors

    I then ran this: yum localinstall *.rpm
    This returns only 10 dependency errors as below

    –> Finished Dependency Resolution
    Error: Package: kopano-python3-extras-0.1.2+0-50.1.x86_64 (/kopano-python3-extras-0.1.2+0-50.1.x86_64)
    Requires: /opt/rh/rh-python36/root/usr/bin/python3
    Error: Package: kopano-spamd-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-spamd-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: /bin/python3
    Error: Package: kopano-python3-extras-0.1.2+0-50.1.x86_64 (/kopano-python3-extras-0.1.2+0-50.1.x86_64)
    Requires: libpython3.6m.so.rh-python36-1.0()(64bit)
    Error: Package: kopano-backup-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-backup-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: /bin/python3
    Error: Package: kopano-migration-pst-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-migration-pst-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: /bin/python3
    Error: Package: kopano-python-utils-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-python-utils-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: /bin/python3
    Error: Package: kopano-presence-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-presence-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: /bin/python3
    Error: Package: kopano-search-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-search-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: /bin/python3
    Error: Package: kopano-presence-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-presence-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: python3-sleekxmpp
    Error: Package: kopano-dagent-pytils-8.7.80.936.529d71bca-190.1.x86_64 (/kopano-dagent-pytils-8.7.80.936.529d71bca-190.1.x86_64)
    Requires: /bin/python3
    You could try using --skip-broken to work around the problem


    Is that Kopano Core package not compatible with CentOS?
    Is there a way to fix that?

    Thanks and regards


  • Kopano

    Hi,

    thanks for testing.

    The package kopano-python3-extras is currently not required and not yet installable on RHEL_7 with EPEL_7 so do not install it. We will need to see what we can do do omit it from the tgz for the time being.

    Similarly kopano-presence currently requires python3-skeelxmpp which is not available for Python 3.6 in EPEL_7 and thus cannot be installed at the moment.

    The rest should work since /bin/python3 is provided by EPEL_7 .

    I hope this helps.

    Best regards



  • Is that Kopano Core package not compatible with [base] CentOS?

    There is currently some reorganization going on. Unfortunately, python2 demotion was approved in the source tree before that process was complete. It is still the goal (my goal) to keep KGWC on RHEL working.



  • Hi @jengelh ,
    i hope, you will achieve your goal soon :)

    Maybe you can help me with an other CentOS 7 EPEL Core Problem.
    After removing “kopano-python3-extras”, “kopano-presence” and the older doubled xapian packages from the RPMs and installed python36 manually, i was able to update via “yum localinstall *.rpm”.
    Same success with kopanoe-webapp.

    But i get an error from httpd with the php-mapi module.

    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/mapi.so' - /usr/lib64/php/modules/mapi.so: undefined symbol: _emalloc_56 in Unknown on line 0
    

    I think, this depends on a wrong PHP version. Which version of PHP are you using from EPEL? I’m still on 5.4.16.

    Best regards,
    Sönke



  • Well looks like you downloaded the RHEL_7_PHP_56 packages, which of course cannot be mixed with 5.4 (use the RHEL_7 target for that).



  • Hi @jengelh ,

    that’s the reason i asked - i haven’t. I’m using a quite old and working (and via ansible installed) kopano-core and can reproduce this.

    server1:/var/opt/install/kopano# ls -1
    core-8.4.90.1116_0
    core-8.7.80.936
    core-8.7.80.936-RHEL_7_EPEL_7-x86_64.tar.gz
    webapp-3.4.2.1073
    webapp-3.5.6.2286
    webapp-3.5.6.2286+1279-RHEL_7_EPEL_7-noarch.tar.gz
    
    server1:/var/opt/install/kopano# history | grep wget
        5  wget https://download.kopano.io/community/core:/core-8.7.80.936-RHEL_7_EPEL_7-x86_64.tar.gz
       64  wget https://download.kopano.io/community/webapp:/webapp-3.5.6.2286%2B1279-RHEL_7_EPEL_7-noarch.tar.gz
    

    Which version would you use? With PHP56 or the newest one?

    /Sönke


  • Kopano

    @soenke-martens said in Installation of Kopano Core on CentOS 7 not possible:

    RHEL_7_EPEL_7

    this one is meant to be used with php 7.3 from https://rpms.remirepo.net/



  • Hi all,took me some time to figure out the trick but here’s what i did to update my CentOS7 / Epel / PHP5.4 / core-8.4.90.1116_0 to core-8.7.80.936 / PHP 7.3

    • Added only remi-safe and remi-php73 (and not the whole nine yards with the remi-release.rpm)
    • Removed installed kopano-presence as it won’t work for now
    • yum update (Now i had php73 and no problems with php-mapi afterwards)
    • Deleted all devel and debug pakets from the RPMs as well as the xapian duplicates and kopano-presence
    • Installed python36 aside of the existing python2
    • yum localinstall *.rpm
    • Apply changes to config files
    • In my case “kopano-dbadm k-1216” and “kopano-dbadm usmp”

    And voila, it worked!
    But on the bright side i got the “built-in function delete_IMAPITable” in kopano-backup and kopano-search…(Irgendwas ist ja immer :)

    Just my 5 cents


Log in to reply