Q: Z-Push on a Raspberry Pi



  • Dear Kopano community,

    after numerous (failed) approaches on a Synology DS I’d like to know if anybody of you have successfully installed a recent version of Z-Push on a Raspberry Pi?

    I’d very much like to use Z-Push on the Raspberry Pi as a pushing service for our mobile devices on iOS to communicate with our perfectly running CalDAV, CardDAV and IMAP services on the Synology DS. But when I try to download the necessary software the following is happening:

    sudo apt-get install z-push-config-apache z-push-backend-caldav z-push-backend-carddav z-push-backend-imap z-push-backend-combined z-push-ipc-sharedmemory
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package z-push-config-apache
    E: Unable to locate package z-push-backend-caldav
    E: Unable to locate package z-push-backend-carddav
    E: Unable to locate package z-push-backend-imap
    E: Unable to locate package z-push-backend-combined
    E: Unable to locate package z-push-ipc-sharedmemory
    

    I’ve now been thankfully told by fbartels that this is most probably due to the fact that I’ve not added the necessary repository to the Raspberry Pi. Adding it should be no bigger problem but before doing so it would be good to know if it is also necessary to install a “real” Debian on the Raspberry Pi like shown here (= slight nightmare but more or less imaginable if everything goes well) or if a standard Raspbian distribution like this one would be sufficient?

    cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="9"
    VERSION="9 (stretch)"
    ID=raspbian
    ID_LIKE=debian
    HOME_URL="http://www.raspbian.org/"
    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
    

    If Rasbian already is a stable home for this little project it would certainly make my day. But then which specific distribution version of Z-Push should I select?

    Your help is very much appreciated!


  • Kopano

    Hi nexttoyou,

    if your system has the necessary Z-Push dependencies (php-imap, php-curl, php-xml etc) and a webserver, then you don’t have to install “real” Debian. As your release is based on stretch, you should use Debian 9 repository (http://repo.z-hub.io/z-push:/final/Debian_9.0/). (Z-Push is actually only a bunch of PHP files, so it probably would work with any Debian repository anyway).

    Manfred


Log in to reply