2.5.0 beta1 - Errors in z-push-top.php



  • I just updated to the latest beta for CentOS 6 and am getting errors running z-push-top.php using php version rh-php56

    PHP Fatal error: Declaration of IpcSharedMemoryProvider::__construct() must be compatible with IIpcProvider::__construct($type, $allocate, $class, $serverKey) in /usr/share/z-push/backend/ipcsharedmemory/ipcsharedmemoryprovider.php on line 44

    If I try to run it with rh-php70 I get no error message displayed - but I also get nothing at all displayed



  • I am also getting the same error reported from active connections

    08/04/2019 12:01:42 [11572] [FATAL] [myUser] [myDevice] Fatal error: /usr/share/z-push/backend/ipcsharedmemory/ipcsharedmemoryprovider.php:44 - Declaration of IpcSharedMemoryProvider::__construct($type, $allocate, $class) must be compatible with IIpcProvider::__construct($type, $allocate, $class, $serverKey) (64)



  • In both cases - z-push-top.php and real connections, adding a 4th parameter ($serverKey) to the constructor eliminates the error

    public function __construct($type, $allocate, $class, $serverKey) {
    

    but, as I don’t know what it is used for, I don’t know if there is any other code that is needed to handle it.


  • Kopano

    Hi liverpoolfcfan,

    which repository are you using? It looks like something went wrong during the upgrade.

    IpcSharedMemoryProvider constructor already has the serverKey parameter:

    https://stash.z-hub.io/projects/ZP/repos/z-push/browse/src/backend/ipcsharedmemory/ipcsharedmemoryprovider.php?at=release/2.5

    Manfred



  • This is the content of the z-push.repo file

    [z-push]
    name=Z-Push noarch Enterprise Linux 7 - $basearch
    baseurl=http://repo.z-hub.io/z-push:/pre-final/RHEL_6_PHP_56
    failovermethod=priority
    enabled=1
    gpgcheck=0


  • Kopano

    Hi liverpoolfcfan,

    I’ve dowloaded the rpm from http://repo.z-hub.io/z-push:/pre-final/RHEL_6_PHP_56 and also there IpcSharedMemoryProvider constructor already has the serverKey parameter.

    Manfred



  • Hi Manfred,

    I have checked the repo download and I too can see the $serverKey is in there. However, it looks like that version is not getting pulled down to my system.

    When I run z-push-top.php it reports version number 2.5.0.beta1+0

    The rpm file is labeled with version 2.5.0.beta1+0-215

    If I run yum update it checks the repository but does not pull down the newer file.

    Could there be a switch that wasn’t flicked to publish the newer update?


Log in to reply