Can't enable desktop notification



  • Hi,

    in Deskapp - Einstellungen - Desktop-Benachrichtigungen I am unable to enable desktop notifications. The push button “Berechtigungen anfordern” do not work, I push the Button but nothing happens an the check box “Desktop-Benachrichtigungen für neue E-Mails aktivieren” is always grayed out. This happens on a newly installed Deskapp 2.1.28 on German Windows 10 1803 x64.

    Any ideas how to activate desktop notifications?


  • Kopano

    Hi @WalterHof - are you also not getting any notifications? If I’m not mistaken DeskApp automatically allows notifications from the server you have configured in the profile.


  • Kopano

    @WalterHof

    As @bhuisman already mentions in DeskApp permissions are already allowed. No use for interaction here.
    This was always the case for DeskApp.



  • I found the solution, but it is sad.

    When connecting to the WebApp via HTTP, I can’t enable the desktop notifications, the button seems to be active but do not work.
    When connection via HTTPS (secure), the button “Berechtigungen anfordern” is inactive and I am able set the checkbox to enable desktop notifications. Desktop notifications are work now.

    So the big question, why the button “Berechtigungen anfordern” is tied to the HTTPS protocol?
    For me this makes no sense.


  • Kopano

    This is as expected for Chromium based browser and has been changed for a while now.: API may no longer be used from insecure origins.

    In Firefox you can still use it with HTTP, but you you should always use HTTPS.



  • Marty,

    thank you for clarification.


Log in to reply