missing security permission to do a search within shared attached mailboxes



  • Hello everyone,

    just got a call from a colleague who complaint that a search within a shared attached mailbox does not work. He can search within his own mailbox but cannot make a search on attached storages. He is using Kopano WebApp. He is getting the error that he lacks of security permissions. I tried to assign secretary permission template, also tried full permissions without success.

    I ran a search through the forum and found that there is a python script called “kopano-search-upgrade-findroots.py”. And here is the associated JIRA ticket. I found the explanation in the upgrade manual, too.

    I am not sure if I ever did run this script after Zarafa–>Kopano migration. I did search our kopano running server for this file and found it under /usr/sbin/kopano-search-upgrade-findroots.py

    My question is: Will the execution of this file solve our mentioned issue? Before running this command I want to ensure this won’t harm our running kopano-server in any way. Is it safe to run this command during productional hours, won’t this command stop or crash the processes of Kopano?

    thanks to anyone in advance.


  • Kopano

    @micro

    Yes this script will most likely solve your issue.
    Running this script more than once can’t harm at all , it will just create a FINDER_ROOT folder in all the stores available on the server and add some permissions to it.

    Normally this script is done within several minutes and doesn’t effect the server performance at all



  • did work like a charm, thank you. For those who are interested in: the command ran only a few seconds and no interruption of running services occured.

    Cheers!


Log in to reply