Android devices lose Email sync (multiple accounts, same device, only one account affected at random)



  • I’m using a Samsung Galaxy S9 running Android 9 and using the stock Samsung email app (this issue was also seen with other apps such as BlueMail).

    The device connects to a Zimbra mail server via z-push to sync with two accounts. One account always works, the other always has an issue where after some time or event (disconnected due to being offline or switching from mobile data to wifi and back), one of the two accounts stops syncing email but continues to so sync calendar, contacts and presumably tasks.

    I can’t determine if this is an Android problem or a Z-Push problem. I am leaning towards it being an Android problem because it only started happening after I recently changed to a new phone that runs a newer version of Android (Samsung S7 running Android 8 did not have this issue).

    If I remove one of the two accounts from the phone and re-add it, the problem shifts to the “older” account, meaning the account that was the most recently added is the one that will continue to work. It is almost as if Android can’t handle having two ActiveSync accounts going to the same server/IP address.

    I can temporarily restore service to both accounts by changing the Sync Schedule in Android for the “broken” account from “Auto” to “Manual” then set it back again to “Auto”.

    When things are working fine, the following is shown under “Additional Information” in z-push-top for both accounts:
    Sink x/540s on Calendar Contacts Email Tasks

    When one of the accounts stops working, it changes to:
    Sink x/540s on Calendar Contacts Tasks

    Email is missing and indeed, email is no longer syncing until the Auto -> Manual -> Auto sync schedule toggling.

    z-push-admin -a list -u username shows the following when things are working:
    Synchronized data: Calendars Contacts Emails Tasks

    Sometimes it shows Emails[2] but not always with a higher “Synchronized Folders” value.

    And when it stops working, the expected:

    Synchronized data: Calendars Contacts Tasks

    Has anybody see this behaviour before or has an idea how to start troubleshooting this?



  • Some additional information as I’ve been watching this in real time now. This issue of email stop syncing happens reliably after approximately 1 hour, give or take a few minutes. At this point it does its final sync (as shown by the timestamp in z-push-admin) and then nothing further.

    Currently, z-push-top no longer shows “Email” under additional information and new emails that are arriving in that mailbox are no longer pushed to the phone. If I open the email app on the phone and go to that account, they do show up. But it doesn’t pick up new email unless I pull-down to force a refresh.

    z-push-admin still actually shows “Emails[2]” under synchronized data which is different from what I saw before. Perhaps it’s a matter of time when this updates as the phone is doing whatever-it-is doing (or not doing).


Log in to reply