KOPANO 869 compiled from sources Crash



  • Hi,

    I encountered the Following problem. After compilation on our linux platform, I ve got the Following error message when I start the server in production. It runs well on my tests platform which is the same as production machine. The difference is the number of simultaneous connections
    Until now, I use the kopano 8.6.1 compiled from sources too, which runs without this kind of problem.

    I have recompiled with different option without success.

    Fatal error detected. Please report all following information.
    Wed Mar 27 08:48:04 2019: [crit ] Application kopano-server version: 8.6.9
    Wed Mar 27 08:48:04 2019: [crit ] OS: Linux, release: 4.14.15, version: #9 SMP Thu Aug 23 18:51:36
    CEST 2018, hardware: x86_64
    Wed Mar 27 08:48:04 2019: [crit ] Thread name: z-s: 192.5.60.2
    Wed Mar 27 08:48:04 2019: [crit ] Peak RSS: 12472
    Wed Mar 27 08:48:04 2019: [crit ] Pid 7148 caught SIGSEGV (11), traceback:
    Wed Mar 27 08:48:04 2019: [crit ] Backtrace:
    Wed Mar 27 08:48:04 2019: [crit ] #0. /usr/lib/libkcutil.so.0(+0x29dab) [0x7f6c1190edab]
    Wed Mar 27 08:48:04 2019: [crit ] #1. /usr/lib/libkcutil.so.0(+0x22d8f) [0x7f6c11907d8f]
    Wed Mar 27 08:48:04 2019: [crit ] #2. /usr/lib/libkcutil.so.0(ZN2KC23generic_sigsegv_handlerEPNS
    8ECLoggerEPKcS3_iPK9siginfo_tPKv+0x1ae) [0x7f6c119080de]
    Wed Mar 27 08:48:04 2019: [crit ] #3. /lib64/libpthread.so.0(+0xf670) [0x7f6c0c8e4670]
    Wed Mar 27 08:48:04 2019: [crit ] #4. /usr/lib64/…/lib64/libssl.so.1(SSL_get_error+0x4c) [0x7f6c0
    dc6f73c]
    Wed Mar 27 08:48:04 2019: [crit ] #5. /usr/lib/libgsoapssl++.so(soap_ssl_error+0x27) [0x7f6c10848f
    07]
    Wed Mar 27 08:48:04 2019: [crit ] #6. /usr/sbin/kopano-server() [0x43b81e]
    Wed Mar 27 08:48:04 2019: [crit ] #7. /lib64/libpthread.so.0(+0x7ce2) [0x7f6c0c8dcce2]
    Wed Mar 27 08:48:04 2019: [crit ] #8. /lib64/libc.so.6(clone+0x6d) [0x7f6c0c0ed8cd]
    Wed Mar 27 08:48:04 2019: [crit ] Signal errno: Succès, signal code: 1
    Wed Mar 27 08:48:04 2019: [crit ] Sender pid: 0, sender uid: 0, si_status: 227193558
    Wed Mar 27 08:48:04 2019: [crit ] Signal value: 227193558, faulting address: (nil)
    Wed Mar 27 08:48:04 2019: [crit ] When reporting this traceback, please include Linux distribution
    name (and version), system architecture and Kopano version.
    Wed Mar 27 08:50:25 2019: [=======] Starting kopano-server version 8.6.9 (pid 8444)

    Any Idea will help me greatly

    Thank



  • Hi,

    Some additional information

    This error occurs when outlook /zarafa connector (outlook 2007) synchronise on port 237 / SSL (old installation)

    Compiling and using 867 kopano version seems to not have this problem - (installed and running in the same environment)
    Can be a compatibility problem with zarafa connector ?

    rpatw


  • Kopano

    @rpatw ,

    This is a bug https://jira.kopano.io/browse/KC-1422, will be fixed in the 8.7.1 release

    As we are still busy fixing the caching issue’s(https://jira.kopano.io/browse/KC-1417) there isn’t a release scheduled yet for 8.7.1.


Log in to reply