issue with autodiscover?



  • Hi
    I was wondering if someone could shed some light on the issue im having. Currently have had working the autodiscover. for some odd reason it sometimes work and sometimes it does not i was looking at the logs i was getting this

    26/03/2019 11:13:52 [10396] [ERROR] [#unknown] Unable to complete autodiscover because of ZPushException. Error: Request for a responseschema that is not supported (only mobilesync is supported): http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a
    
    

    any ideas?

    Thank you


  • Kopano

    Hi @killmasta93 ,

    what kind of client are you using? is it by any chance Outlook? If that is the case then when using the search you will find previous posts about this.



  • @fbartels thanks for the reply I was using mail app on samsung what’s bugging me is that 3 days ago was working flawless automatic got the config now it says that the cert is not valid. Clearly it shows let’s encrypt that has not expired so I’m not sure why this is happening. Also getting lots of

    26/03/2019 16:41:55 [ 4340] [ERROR] [sebastian.jaramillo] Ignored broken message (SyncMail). Reason: '2' Folderid: 'i/2a686579' message id '3'
    26/03/2019 16:41:55 [ 4340] [FATAL] [test] Exception: (ProvisioningRequiredException) - Retry after sending a PROVISION command
    

    whats odd is that it says certificate not secure the name of site doesn’t match the name on the certificate not sure why its its configure with mail.mydomain.com whats bugging me is that 3 days ago was working perfectly.



  • edit: after few hours trouble shooting figured out it was a php5 issue i raised the max execution time to 300 but i have been seeing this in the logs
    my question is whats the recomended config for php for zpush?

     in /var/www/zpush/src/index.php on line 102" while reading response header from upstream, client: 192.168.100.7, server: mail.mydomain.com, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "mail.mydomain.com"
    2019/03/26 17:45:02 [error] 26542#0: *548 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 10240 bytes) in /var/www/zpush/src/index.php on line 102" while reading response header from upstream, client: 192.168.100.7, server: mail.mydomain.com, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "mail.mydomain.com"
    2019/03/26 17:45:20 [error] 26541#0: *32 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 6400 bytes) in /var/www/zpush/src/index.php on line 77" while reading response header from upstream, client: 181.54.44.31, server: mail.mydomain.com, request: "POST /Microsoft-Server-ActiveSync?Cmd=Sync&User=mauricio.naranjo&DeviceId=androidc40807009&DeviceType=Android HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "mail.mydomain.com"
    

  • Kopano

    Hi killmasta93,

    what is the memory_limit setting in php.ini?

    There is no the recommended config, it depends on your system, how many active and concurrent users are there, are you using Outlook and so on.

    Manfred



  • Thanks for the reply, i finally fixed it i did the following

    [www]

    user = www-data
    group = www-data
    listen = /var/run/php5-fpm.sock
    listen.owner = www-data
    listen.group = www-data
    listen.mode = 0660

    pm.max_children = 15
    pm.start_servers = 5
    pm.min_spare_servers = 5
    pm.max_spare_servers = 10

    then restart php and worked flawless i think it was because had around 200 users

    hope this helps for someone else


Log in to reply