Email not delivered, sometimes, & mostly to long recipient adresses



  • I have a very strange problem with my Kopano system.

    My system: Univention server 4.3-2 in a Synology Virtual Machine

    Lately, i have been getting reports of 2 people not receiving my emails. Maybe a coincidence, but both have longish email adresses. I sent them both an email including a third adressee, and the third adressee got the email.

    When i resend the email to the people with the longish email adress, sometimes it is delivered succesfully, and sometimes not. I have tried to use different from adressess, but have yet to discover a pattern.

    What i do see in the log is that the email is only sent to one of the three recipients, altough the email is processed by amavis & postfix succesfully.
    Altough seeing a negative number for ‘Hits’ puzzles me.

    Any hints to whats wrong?

    In this log snippet, it is visible that the message only goes out to one of the three recipients (abcd@nfu.nl) (email names scrambled but with the same length as the originals, i left the email domains intact):

    Mar 18 22:59:44 server amavis[8001]: (08001-03) Passed CLEAN {RelayedOutbound}, LOCAL [127.0.0.1]:45858 <abcd@hooftman-consultancy.nl> -> <abcd@nfu.nl>,<a.bcdefghij@nvz-ziekenhuizen.nl>,<a.bcdef@nvz-ziekenhuizen.nl>, Queue-ID: EB5F631C3B32, Message-ID: <kcis.07D84E75716B4144BCB62340E649D5F4@myserver.mydomain.net>, mail_id: TPCLXW4HFJnj, Hits: -0.999, size: 74261, queued_as: 5E1EE31C3B46, 1172 ms
    Mar 18 22:59:44 server postfix/smtp[12975]: EB5F631C3B32: to=<abcd@nfu.nl>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.8, delays=0.44/0.21/0.01/1.2, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 5E1EE31C3B46)
    
    


  • This message was not delivered also, altough the log seems to indicate otherwise:

    Mar 20 15:18:46 server amavis[12972]: (12972-03) Passed CLEAN {RelayedOutbound}, LOCAL [127.0.0.1]:53498 <abcd@hooftman-consultancy.nl> -> <a.bcdefghijklmn@demedischspecialist.nl>, Queue-ID: 048E231C3B32, Message-ID: <kcis.78FB4EB9E7A14DDC8172137E74E83A3F@myserver.mydomain.net>, mail_id: 9m-9xjjn2cd7, Hits: 0.085, size: 352282, queued_as: 33BE731C3B59, 3345 ms
    Mar 20 15:18:46 server postfix/smtp[22088]: 048E231C3B32: to=<a.bcdefghijklmn@demedischspecialist.nl>, relay=127.0.0.1[127.0.0.1]:10024, delay=9.6, delays=6.2/0.04/0.01/3.3, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 33BE731C3B59)
    Mar 20 15:18:46 server postfix/smtp[22095]: 33BE731C3B59: to=<a.bcdefghijklmn@demedischspecialist.nl>, relay=smtp.caiway.nl[62.45.45.128]:587, delay=0.57, delays=0.39/0.04/0.08/0.06, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as D0EB4E0086)
    

  • Kopano

    Hi @pwhooftman ,

    especially if the mail.log lists the message as delivered it means that the message has left the system and can only get lost (maybe marked as spam) on the receiving end.

    If there are indeed messages being lost between postfix and Kopano, the the logging of kopano-spooler is interesting.



  • I am having a hard time location the kopano-spooler log file (or determine kopano-spooler settings as a whole).

    /usr/sbin/kopano-spooler --dump-config gives me:

    Administrator@server:~$ sudo /usr/sbin/kopano-spooler --dump-config
    [sudo] wachtwoord voor Administrator:
    # allow_delegate_meeting_request = yes
    # allow_redirect_spoofing = yes
    # allow_send_to_everyone = yes
    # always_send_delegates = no
    # always_send_tnef = no
    # archive_on_send = no
    # charset_upgrade = windows-1252
    # copy_delegate_mails = yes
    # coredump_enabled = systemdefault
    # enable_dsn = yes
    # expand_groups = no
    # fax_domain =
    # fax_international = +
    # log_buffer_size = 0
    # log_file = -
    # log_level = 3
    # log_method = file
    # log_raw_message_path = /tmp
    # log_raw_message_stage1 = no
    # log_timestamp = 1
    # max_threads = 5
    # pid_file = /var/run/kopano/spooler.pid
    # plugin_enabled = yes
    # plugin_manager_path = /usr/share/kopano-spooler/python
    # plugin_path = /var/lib/kopano/spooler/plugins
    # run_as_group = kopano
    # run_as_user = kopano
    # running_path = /var/lib/kopano
    # server_socket = default:
    # smtp_port = 25
    # smtp_server = localhost
    # sslkey_file =
    # sslkey_pass =
    # tmp_path = /tmp
    # z_statsd_stats = /var/run/kopano/statsd.sock
    Administrator@server:~$
    

    I am a bit stumped that this doesn’t even show my providers stmp server… (i entered this previously in /etc/postfix/smtp_auth).

    The kopano spooler seems to be running though (twice):

    Administrator@server:~$ ps -ax | grep kopano
      721 ?        Ssl    1:59 /usr/sbin/kopano-monitor -F
      722 ?        Ssl   36:28 /usr/bin/python2 /usr/sbin/kopano-search -F
      726 ?        Ss     0:19 /usr/sbin/kopano-ical -F
      728 ?        Ss     0:21 /usr/sbin/kopano-gateway -F
      732 ?        Ssl    4:47 /usr/sbin/kopano-spooler -F
      733 ?        Ssl    0:22 /usr/sbin/kopano-dagent -l
      798 ?        S      0:02 /usr/sbin/kopano-dagent -l
      800 ?        S      0:00 /usr/sbin/kopano-spooler -F
     1452 pts/1    S+     0:00 grep kopano
     1972 ?        S     32:36 /usr/bin/perl /usr/share/kopano-webapp/plugins/fetchmail/php/daemon/kopano_fetchmail.pl --start
     2357 ?        Sl    13:26 /usr/bin/python2 /usr/sbin/kopano-search -F
     2359 ?        S      0:25 /usr/bin/python2 /usr/sbin/kopano-search -F
    31124 ?        Ssl   38:16 /usr/sbin/kopano-server -F
    Administrator@server:~$
    

  • Kopano

    @pwhooftman said in Email not delivered, sometimes, & mostly to long recipient adresses:

    I am a bit stumped that this doesn’t even show my providers stmp server… (i entered this previously in /etc/postfix/smtp_auth).

    the command only prints the configuration of kopano-spooler and not postfix.

    @pwhooftman said in Email not delivered, sometimes, & mostly to long recipient adresses:

    (twice)

    that is expected and no problem at all

    @pwhooftman said in Email not delivered, sometimes, & mostly to long recipient adresses:

    I am having a hard time location the kopano-spooler log file

    You various information on debugging Kopano on Univention (including where to find logging) at https://wiki.z-hub.io/display/K4U/Debugging+Kopano+on+Univention



  • A, thank you very much.

    journalctl was the command i was looking for, but yet to find any entry made by kopano-spooler or kopano_spooler.

    But what i did find that all messages in my mail log snippets where indeed sent to my providers smtp server, so i have to take my problem to my provider.

    Thanks for your patience!



  • Just one more question: is it possible to get delivery confirmations (not read confirmations) by some setting somewhere? Delivery confirmation works when sending from Outlook 2016, but i’d rather use the Kopano Webapp.


Log in to reply