install on Debian Buster



  • This Kopano newbie installed the kopano-* packages on Debian Buster. I followed some docs but the server refuses to contact the LDAP server. The LDAP server is working correctly, has the kopano schemas and an admin user.

    server_listen = *:236
    database_engine = mysql
    local_admin_users = root kopano
    system_email_address = postmaster@kopano1.domain.tld
    run_as_user = kopano
    run_as_group = kopano
    mysql_user = kopano
    mysql_password = password
    mysql_socket = /var/run/mysqld/mysqld.sock
    user_plugin = ldap
    user_plugin_config = /etc/kopano/ldap.cfg
    !include debian-db.cfg
    
    !include /usr/share/kopano/ldap.openldap.cfg
    ldap_bind_user = cn=admin,dc=domain,dc=tld
    ldap_bind_password = password
    ldap_search_base = dc=domain,dc=tld
    ldap_uri = ldap://localhost:389/
    ldap_user_search_filter = (uid=*)
    

    The kopano-server isn’t even trying to contact the ldap server (tcpdump shows that and a “slapd -d 65535” remains silent). A simple test shows:

    kopano-admin -l -vvvvvvv
    [debug  ] Initializing provider "Kopano Directory Service"
    [debug  ] Initializing provider "Private Folders"
    [debug  ] Initializing provider "Public Folders"
    Unable to list users: "object" not found
    

    Anyone a hint?

    Richard.


  • Kopano

    Hi @Richard-Lucassen ,

    @Richard-Lucassen said in install on Debian Buster:

    ldap_bind_password

    the option is actually called ldap_bind_passwd. (and its not deprecated, at least not in our codebase)

    Edit: ah just noticed its indeed mentioned wrongly in one of the example code blocks in your linked page. I just corrected this.



  • Apparently the option “ldap_bind_password” has been deprecated.

    R.


  • Kopano

    Hi @Richard-Lucassen ,

    @Richard-Lucassen said in install on Debian Buster:

    ldap_bind_password

    the option is actually called ldap_bind_passwd. (and its not deprecated, at least not in our codebase)

    Edit: ah just noticed its indeed mentioned wrongly in one of the example code blocks in your linked page. I just corrected this.



  • Ah, ok, must be some typo I think. Fortunately the logging can be set to verbose debugging. Anyway, I now get “Unknown MAPI Error: MAPI_E_NOT_FOUND”. That will be the next challenge :)


  • Kopano

    @Richard-Lucassen said in install on Debian Buster:

    MAPI_E_NOT_FOUND

    usually means that the user does not have a store.



  • I already found some questions on this forum about the MAPI_E_NOT_FOUND. I will first have to find out what that means. I’ll dive into the docs.

    BTW: the docs do not correspond to the Buster install, I fear it’s too recent. Files and dirs have been renamed and the example-config dir is almost empty using the Buster packages.

    Richard.


  • Kopano

    Hi @Richard-Lucassen,

    @Richard-Lucassen said in install on Debian Buster:

    BTW: the docs do not correspond to the Buster install

    that can indeed be the case. Our documentation refers to the our own packaging. The Debian maintainers did apparently make a few different design decisions.



  • Ok, if I don’t succeed, I’ll take a Debian9 or Debian8 image and install the Kopano packages. I thought these Buster packages were provided by Kopano.

    Thnx for your replies!

    R.



  • Oh, btw, e.g. on this documentation page you will be nominated for The Useless Use Of Cat Award ;-)

    E.g.:

    sudo cat /var/log/syslog |grep bdb_equality_candidates
    
    grep bdb_equality_candidates /var/log/syslog
    

    or

    sudo cat optimize-index.ldif | ldapmodify -Y EXTERNAL -H ldapi:///
    
    sudo ldapmodify -Y EXTERNAL -H ldapi:///  <optimize-index.ldif
    

    :-)

    Richard.



  • I just added a store and at a first glance it seems to work well. The only thing is that it says that the HomeServer is “unknown”:

    kopano-cli --list-users
    User list for Default (2):
    User             Full Name            Homeserver          
    ----------------------------------------------------------
    SYSTEM           SYSTEM               Unknown             
    richard          Richard Lucassen     Unknown
    

    Where can I set that? In LDAP there is a “kopanoUserServer” attribute with value “kopano”, but that doesn’t seem to do the job. AFAICS there’s no setting in server.cfg

    Richard.


  • Kopano

    Hi @Richard-Lucassen,

    kind of kopanoUserServer would be the ldap attribute if your are running a multi-server installation (multiple kopano-server processes running as once system). In a non “distributed” kopano this attribute is not needed. To get rid of the “Unknown” you will want to set server_name in your server.cfg.



  • Ok, thnx Felix!

    BTW: how can I add “solved” at the title of this post? I can see an “unsolved” tag at the post “Kopano Installation in UBUNTU 18.04”.

    R.


  • Kopano

    @Richard-Lucassen this is something I also always forget, therefore I tried it myself. You have to set this thread as a question from the topic tools, once its a “question” you can mark it as solved.



  • Ok, thnx.


Log in to reply