dagent issue: Unknown option 'lmtp_listen' on opensuse 42.3



  • Hi everyone,

    I try to install and configure kopano on a opensuse but I have an issue with dagent…

    I followed the steps describe in the documentation :

    • adding lmtp_listen = unix:/var/spool/kopano/dagent.sock in dagent.cfg
    • adding virtual_transport = lmtp:unix:/var/spool/kopano/dagent.sock in the main.cfg of postfix

    I create the directory /var/spool/kopano :

    kopanotest:/var/spool # ll
    drwxrwx---+ 1 kopano kopano   0 Feb 21 10:00 kopano
    

    And when I try to start kopano-dagent, it doesn’t start and when I look to the log I get this line :

    Thu Feb 21 10:00:41 2019: [crit   ] Config error: Unknown option 'lmtp_listen' found!
    

    Thanks in advance for your support.


  • Kopano

    Hi @kmailleux ,

    this indicates that you are using an older version that does not yet have this parameter. Which version of Kopano are you using?



  • Hi fbartels,

    Thanks for your quick reply.

    I’m using Kopano Core: 8.3.3.24-37. It’s the one provided directly by the package manager from openSUSE 42.3.

    Following your message, I see that in opensuse 15 it’s Kopano Core: 8.6…


  • Kopano

    @kmailleux said in dagent issue: Unknown option 'lmtp_listen' on opensuse 42.3:

    8.3.3.24-37

    Without checking changelogs this option was either introduced with 8.6 or 8.7 (i think the latter).



  • Ok many thanks fbartels !

    I will upgrade my installation.

    Best regards.


Log in to reply