Outlook 2016 (office 365) problems

Hi everyone,

Does anayone has any problems using outlook 2016 with kopano plugin. My setup is now verry slow and never reaches the 100 % with downloading from the server.

I have all latest versions. office 2016 up to date and kopano 32 bit version 2.0.333

Hi @ckruijntjens

I am using latest Outlook Office 365 and sync is working (however, the initial sync with thousands of objects was a little bit problematic). How many mails/contacts/notes/… are stored in your mailbox? You can check the sync state of all your devices with z-push-admin -a list -u user. It is also possible to trigger a full resync with z-push-admin. You can also try to the delete the account in Outlook (or delete the .ost) and recreate it (helped for my initial sync).

hi @ashceryth

in my zpush log i have the following

Mobile loop detected! Messages sent to the mobile will be restricted to 1 items in order to identify the conflict

how can i see what item is the problem an resolve it

This page describes the issue:
https://wiki.z-hub.io/display/ZP/Loop+detection

Do you see errors in the Attention needed line for the Outlook device when issuing z-push-admin -a list -u user?

hi no. i tested some further and i have this with all users. (outlook 2016).

this is the message:

03/01/2019 23:01:06 [16491] [ERROR] [chris] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.
03/01/2019 23:01:07 [16491] [WARN] [chris] KopanoBackend->openMessageStore(‘SYSTEM’): No store found for this user
03/01/2019 23:01:07 [16491] [WARN] [chris] DeviceManager->GetAdditionalUserSyncFolders(): setup for store ‘SYSTEM’ failed. Unable to search for KOE GAB folder.
03/01/2019 23:06:49 [16494] [ERROR] [marcel] ZPushAdmin::AdditionalFolderList(): state for device ‘476ae2e57de04134ab8930f7d1d816ef’ of user ‘marcel’ can not be found
03/01/2019 23:06:49 [16479] [ERROR] [marcel] LoopDetection->ProcessLoopDetectionPreviousConnectionFailed(): Command ‘FolderSync’ at 03/01/2019 23:06:49 with pid ‘16478’ terminated unexpectedly or is still running.
03/01/2019 23:06:49 [16479] [ERROR] [marcel] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.

03/01/2019 23:32:49 [16791] [WARN] [chris] /usr/share/z-push/backend/kopano/kopano.php:168 mapi_logon_zarafa(): Unable to setup service for provider (2)

Hi ckruijntjens,

the log you’ve posted is not enough to identify the issue. WBXML log would be more helpful.

Which KC and Z-Push versions are you using? Did you update any of them recently? Are you able to login into webapp?

Did you check apache logs for errors?

Manfred

@Manfred

0_1546645947976_3a274789-b8e3-48a3-b35c-3f7677a9aa40-image.png

WBXML is enabled. no errors found on apache site or php-fpm. i see this on my z-push system. could this be the problem. (iphone is syncing ok)

05/01/2019 00:38:57 [ 4362] [ERROR] [chris] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.
05/01/2019 00:43:48 [ 5160] [WARN] [chris] ImportChangesICS->lazyLoadConflicts(): conflict detection abandoned as there are too many (205) changes to be exported.
05/01/2019 00:48:35 [ 5157] [WARN] [chris] KopanoBackend->openMessageStore('SYSTEM'): No store found for this user
05/01/2019 00:48:35 [ 5157] [WARN] [chris] DeviceManager->GetAdditionalUserSyncFolders(): setup for store 'SYSTEM' failed. Unable to search for KOE GAB folder.
05/01/2019 00:48:35 [ 4108] [WARN] [chris] ImportChangesICS->lazyLoadConflicts(): conflict detection abandoned as there are too many (205) changes to be exported.
05/01/2019 00:38:57 [ 4362] [ERROR] [chris] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.
05/01/2019 00:43:48 [ 5160] [WARN] [chris] ImportChangesICS->lazyLoadConflicts(): conflict detection abandoned as there are too many (205) changes to be exported.
05/01/2019 00:48:35 [ 5157] [WARN] [chris] KopanoBackend->openMessageStore('SYSTEM'): No store found for this user
05/01/2019 00:48:35 [ 5157] [WARN] [chris] DeviceManager->GetAdditionalUserSyncFolders(): setup for store 'SYSTEM' failed. Unable to search for KOE GAB folder.
05/01/2019 00:48:35 [ 4108] [WARN] [chris] ImportChangesICS->lazyLoadConflicts(): conflict detection abandoned as there are too many (205) changes to be exported.

Hi ckruijntjens,

the log you’ve posted is not helpful. Those are error/warn messages from various requests. More information regarding debugging is available here: https://wiki.z-hub.io/display/ZP/Debugging .

Manfred

Hi @Manfred

this is from my z-push log

Hi ckruijntjens,

It looks like there are some messages Outlook is not able to process and syncs them over and over again causing loop detection to kick. Unfortunately there’s no simple response or a pattern to follow how to identify such items. You have to search the log for such broken items and check if you see something obviously wrong and then fix them or exclude them from sync. Some times it helps just to open such an item in webapp and save it.
One example would be ziektemeldingen contact. It doesn’t have a last name. I don’t know if that’s causing Outlook to not process this item, but it might be.
Search the log for “potential broken” and you’ll find another items which end up in loop. Or run z-push-admin -u user -d deviceid which will also list ignored items.

Manfred

@Manfred

Hi Manfred. the strange thing is that it happens with all users.

Hi ckruijntjens,

in my experience Outlook (every version) over ActiveSync breaks very easy causing loops or not syncing at all, so it’s not really surprising that almost everyone using such a setup sooner or later runs into some issues. Unfortunately it’s also not something we can easy fix in Z-Push or KOE as they are Outlook problems.

Manfred

@Manfred

hi manfred just tested some more. if i use outlook 365 with latest kopano plugin syncing wont work.

if i use outlook 2016 with latest kopano plugin all my mail is synced within 10 minutes

this has defefinitly something to do with the office versions. maybe this is something you wanna know.