Kopano-spamd not starting because of No module named '_MAPICore'No module named '_MAPICore'



  • Hi Everybody,
    I have installed kopano-core 8.7.80.307, working okay.
    But the kopano-spamd ist not coming up because of:

    File “/usr/lib/python3/dist-packages/MAPICore.py”, line 18, in swig_import_helper
    return importlib.import_module(mname)
    File “/usr/lib/python3.7/importlib/init.py”, line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
    File “<frozen importlib._bootstrap>”, line 1006, in _gcd_import
    File “<frozen importlib._bootstrap>”, line 983, in _find_and_load
    File “<frozen importlib._bootstrap>”, line 965, in _find_and_load_unlocked
    ModuleNotFoundError: No module named ‘_MAPICore’

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File “/usr/sbin/kopano-spamd”, line 4, in <module>
    import kopano_spamd
    File “/usr/lib/python3/dist-packages/kopano_spamd/init.py”, line 8, in <module>
    import kopano
    File “/usr/lib/python3/dist-packages/kopano/init.py”, line 55, in <module>
    from .config import Config, CONFIG
    File “/usr/lib/python3/dist-packages/kopano/config.py”, line 16, in <module>
    from . import utils as _utils
    File “/usr/lib/python3/dist-packages/kopano/utils.py”, line 15, in <module>
    from MAPI import (
    File “/usr/lib/python3/dist-packages/MAPI/init.py”, line 4, in <module>
    from MAPICore import *
    File “/usr/lib/python3/dist-packages/MAPICore.py”, line 21, in <module>
    _MAPICore = swig_import_helper()
    File “/usr/lib/python3/dist-packages/MAPICore.py”, line 20, in swig_import_helper
    return importlib.import_module(’_MAPICore’)
    File “/usr/lib/python3.7/importlib/init.py”, line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
    ModuleNotFoundError: No module named ‘_MAPICore’

    But I have installed everything without Errors.

    So any Ideas?

    Thank you.
    Regards
    Thomas


  • Kopano

    Hi @jonny12 ,

    what distribution are you using?



  • If someone is coming from Google to this page as he/she has the same error (like me g), check if you’ve incompatible versions of the python3 packages. I mixed them up with stable/unstable. After downgrading anything works fine.

    By the way I wasn’t able to start kopano-search - but with the same error.

    Best wishes


Log in to reply