PHP7.x (>7.0) support in Kopano MAPI

  • Hello fellow Kopano users,

    I am using Debian Stretch and Kopano Core 8.70.x. I was wondering if Kopano MAPI supports PHP Versions > 7.0. I was updating PHP yesterday, but it seems the mapi packages in Kopano require 7.0. Or am I missing something?

    Error message when upgrading Kopano, after switchting to PHP7.3:

    php7-mapi depends on phpapi-20151012

    Kind regards

  • Kopano


    php-mapi needs to be compiled against a specific PHP version and at the moment we only do that for the version that is shipped by default with the OS and for stretch its PHP 7.0 at the moment.

  • @robing

    thanks. I see I was trying to compile kopano core from source but I received an error at one point so I stopped. Is there a chance to compile php-mapi separately instead of the entire core?

  • Have a look at the Debian kopano-sources i saw that they dynamicly detect the php version for the build now.
    Debian git commit : [4e86b06] d/rules: detect PHP_VERSION dynamically
    so i suggest try the Debian sid source and look at Debian/rules

Log in to reply