Update Issue Ubuntu 16.04 supported packages (archiver, ldap user plugin)

Good morning,

currently it seems to be an issue to update Kopano in Ubuntu 16.04:

Preparing to unpack .../kopano-archiver_8.6.9.0-0+24.1_amd64.deb ...
Unpacking kopano-archiver (8.6.9.0-0+24.1) over (8.6.8.0-0+21.1) ...
dpkg: error processing archive /var/cache/apt/archives/kopano-archiver_8.6.9.0-0+24.1_amd64.deb (--unpack):
 trying to overwrite '/etc/init.d/kopano-spooler', which is also in package kopano-spooler 8.6.8.0-0+21.1
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for systemd (229-4ubuntu21.10) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kopano-archiver_8.6.9.0-0+24.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Best regards

Andreas

Actually there seems to be more broken with currently tested and supported packages for ubuntu 16.04. To get system updated I removed kopano-archiver package and afterwards this mess can be found in Logiles:

Fri Nov 30 07:07:25 2018: [error  ] libkcserver-ldap.so: Plugin version "8.6.9", but server is "8.6.8"
Fri Nov 30 07:07:25 2018: [crit   ] Unable to instantiate user plugin
Fri Nov 30 07:07:25 2018: [crit   ] ERROR: Unable to find server information on LDAP for 'mail.abrhome.lan', error 0x80000002. Check your server name.
Fri Nov 30 07:07:25 2018: [info   ] Shutdown notification manager

… there was nothing changed in LDAP and the record is there. Additionally server version is:

# kopano-server -V
kopano-server 8.6.9

Don’t know what happened exactly with the packages available in repo currently but it seems that everyone should to wait with installing them.

Andreas

There have been no problems with the packages in our test environment. Have you been able to replicate your issues on another system?

Ps: and I have also other confirmations on successful upgrades to 8.6.9.

@fbartels
Thanks for reply.

The problem seems to be in multi server installations (i.e. in archiver context) using ldap. Issue happens on my old updated main system with quite good version history and even on fresh installed archive server. All running Ubuntu 16.04 latest version, all accessing LDAP Server based on Zarafa Props (sorry - no time to update this until now …)

Besides this - there are currently no 8.6.9 Packages available for Ubuntu 14.04…

Andreas

I am currently seeing the same issue on Ubuntu 16.04 in an environment with a separate archive server. I am going to try to install from the packages in the portal, and then fall back if it doesn’t work.

EDIT:
Running this command worked:
rm /var/lib/dpkg/info/$nomdupaquet* -f
Not sure why, I can’t really find any information on what those files do. I assume it has something to do with allowing packages to overwrite files that are included in other packages, since the error was
“trying to overwrite ‘/etc/init.d/kopano-spooler’, which is also in package kopano-spooler 8.6.8.0-0+21.1”

@fbartels said in Update Issue Ubuntu 16.04 supported packages (archiver, ldap user plugin):

There have been no problems with the packages in our test environment. Have you been able to replicate your issues on another system?

Ps: and I have also other confirmations on successful upgrades to 8.6.9.

Any idea in the meantime about this issue? The package kopano-archiver_8.6.9.0-0+24.1_amd64.deb seems actually being broken for me, since in package I find CONTENTS/etc/init.d/ all kopano-* init scripts:

dpkg -c kopano-archiver_8.6.9.0-0+24.1_amd64.deb
drwxr-xr-x root/root         0 2018-11-28 13:09 ./
drwxr-xr-x root/root         0 2018-11-28 13:08 ./usr/
drwxr-xr-x root/root         0 2018-11-28 13:08 ./usr/share/
drwxr-xr-x root/root         0 2018-11-28 13:08 ./usr/share/man/
drwxr-xr-x root/root         0 2018-11-28 13:09 ./usr/share/man/man5/
-rw-r--r-- root/root      3050 2018-11-28 13:08 ./usr/share/man/man5/kopano-archiver.cfg.5.gz
drwxr-xr-x root/root         0 2018-11-28 13:09 ./usr/share/man/man8/
-rw-r--r-- root/root      2179 2018-11-28 13:08 ./usr/share/man/man8/kopano-archiver.8.gz
-rw-r--r-- root/root      1714 2018-11-28 13:08 ./usr/share/man/man8/kopano-archiver-restore.8.gz
-rw-r--r-- root/root      1293 2018-11-28 13:08 ./usr/share/man/man8/kopano-archiver-aclsync.8.gz
-rw-r--r-- root/root      1213 2018-11-28 13:08 ./usr/share/man/man8/kopano-archiver-aclset.8.gz
drwxr-xr-x root/root         0 2018-11-28 13:08 ./usr/share/doc/
drwxr-xr-x root/root         0 2018-11-28 13:09 ./usr/share/doc/kopano-archiver/
-rw-r--r-- root/root       219 2018-11-28 12:56 ./usr/share/doc/kopano-archiver/changelog.Debian.gz
-rw-r--r-- root/root     34520 2018-11-28 12:56 ./usr/share/doc/kopano-archiver/copyright
drwxr-xr-x root/root         0 2018-11-28 13:08 ./usr/share/doc/kopano/
drwxr-xr-x root/root         0 2018-11-28 13:09 ./usr/share/doc/kopano/example-config/
-rw-r--r-- root/root      1657 2018-11-28 13:08 ./usr/share/doc/kopano/example-config/archiver.cfg.gz
drwxr-xr-x root/root         0 2018-11-28 13:09 ./usr/sbin/
-rwxr-xr-x root/root     31232 2018-11-28 13:09 ./usr/sbin/kopano-archiver
-rwxr-xr-x root/root      2620 2018-11-28 13:08 ./usr/sbin/kopano-archiver-restore
-rwxr-xr-x root/root      2159 2018-11-28 13:08 ./usr/sbin/kopano-archiver-aclsync
-rwxr-xr-x root/root      1646 2018-11-28 13:08 ./usr/sbin/kopano-archiver-aclset
drwxr-xr-x root/root         0 2018-11-28 13:08 ./etc/
drwxr-xr-x root/root         0 2018-11-28 13:08 ./etc/init.d/
-rwxr-xr-x root/root      1989 2018-11-28 12:56 ./etc/init.d/kopano-spooler
-rwxr-xr-x root/root      2278 2018-11-28 12:56 ./etc/init.d/kopano-server
-rwxr-xr-x root/root      2036 2018-11-28 12:56 ./etc/init.d/kopano-search
-rwxr-xr-x root/root      2068 2018-11-28 12:56 ./etc/init.d/kopano-presence
-rwxr-xr-x root/root      1983 2018-11-28 12:56 ./etc/init.d/kopano-monitor
-rwxr-xr-x root/root      1937 2018-11-28 12:56 ./etc/init.d/kopano-ical
-rwxr-xr-x root/root      1990 2018-11-28 12:56 ./etc/init.d/kopano-gateway
-rwxr-xr-x root/root      2001 2018-11-28 12:56 ./etc/init.d/kopano-dagent
drwxr-xr-x root/root         0 2018-11-28 13:08 ./etc/kopano/
-rw-r--r-- root/root      4238 2018-11-28 13:08 ./etc/kopano/archiver.cfg

Same for this Package in Ubuntu 18.04. The previews package did not have these files in…

dpkg -c kopano-archiver_8.6.8.0-0+21.1_amd64.deb
drwxr-xr-x root/root         0 2018-10-03 11:57 ./
drwxr-xr-x root/root         0 2018-10-03 11:57 ./etc/
drwxr-xr-x root/root         0 2018-10-03 11:57 ./etc/kopano/
-rw-r--r-- root/root      4238 2018-10-03 11:57 ./etc/kopano/archiver.cfg
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/sbin/
-rwxr-xr-x root/root     31232 2018-10-03 11:57 ./usr/sbin/kopano-archiver
-rwxr-xr-x root/root      1646 2018-10-03 11:57 ./usr/sbin/kopano-archiver-aclset
-rwxr-xr-x root/root      2159 2018-10-03 11:57 ./usr/sbin/kopano-archiver-aclsync
-rwxr-xr-x root/root      2620 2018-10-03 11:57 ./usr/sbin/kopano-archiver-restore
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/doc/
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/doc/kopano/
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/doc/kopano/example-config/
-rw-r--r-- root/root      1657 2018-10-03 11:57 ./usr/share/doc/kopano/example-config/archiver.cfg.gz
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/doc/kopano-archiver/
-rw-r--r-- root/root     34520 2018-10-03 11:33 ./usr/share/doc/kopano-archiver/copyright
-rw-r--r-- root/root       220 2018-10-03 11:33 ./usr/share/doc/kopano-archiver/changelog.Debian.gz
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/man/
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/man/man8/
-rw-r--r-- root/root      1213 2018-10-03 11:57 ./usr/share/man/man8/kopano-archiver-aclset.8.gz
-rw-r--r-- root/root      1293 2018-10-03 11:57 ./usr/share/man/man8/kopano-archiver-aclsync.8.gz
-rw-r--r-- root/root      1714 2018-10-03 11:57 ./usr/share/man/man8/kopano-archiver-restore.8.gz
-rw-r--r-- root/root      2179 2018-10-03 11:57 ./usr/share/man/man8/kopano-archiver.8.gz
drwxr-xr-x root/root         0 2018-10-03 11:57 ./usr/share/man/man5/
-rw-r--r-- root/root      3050 2018-10-03 11:57 ./usr/share/man/man5/kopano-archiver.cfg.5.gz

So it would be nice to get the 8.6.9 archiver package fixed and apt is right while installing these package in update scenarios.

Best regards

Andreas

Hi @dw2412 ,

I am this week not in the office, but for anything critical I would anyways always recommend to open a support case over posting in the forum.

@fbartels Did as requested ( KS-42204 ) I hope they will not reduce my Support blocks ;-)

Andreas

@fbartels unfortunately no one replied to the ticket or fixed the packages until now. May I ask you if it makes no sense for your collegues to have a look at or at least react on ticket if there is information about that there is a problem with supported packages?

Andreas

The last I remembered the auto reply to an opened support case includes a phone number. So if you do not get email reies I probably helps calling.

As for the support blocks:

What happens if the issue I reported turns out to be a bug in your software?
When a reported issue turns out to be a bug which can be reproduced in the latest version of our officially supported software versions, no support blocks will be charged at Kopano’s discretion.

Source: https://kopano.com/support-info/

@fbartels the comment about support blocks was with a smile while the one about open unanswered support ticket was not.

Actually I wanted just to help Kopano in its promise to provide supported, tested packages to subscription customers, so my thought was that it should be in Kopano’s interest to take my note serious…

Regarding autoreply message on support tickets:

“If you experience a ‘system down’ situation, please call +31(0)15-xxxxxxxx after creating the ticket” - since this is not the case I did not do.

"Phone support is available with a Professional or Enterprise subscription. " - sorry… I don’t have and therefor I didn’t call.

Andreas

@dw2412 said in Update Issue Ubuntu 16.04 supported packages (archiver, ldap user plugin):

Phone support is available with a Professional or Enterprise subscription. " - sorry… I don’t have and therefor I didn’t call.

If you do not have a pro subscription then you anyways do not have support on multiserver functionality (which seems to be what you are using according to your error message). Anyways I asked support to get in contact with you

@fbartels this I didn’t expect since you’re not in office. Thanks for help. And well - I’m still using Kopano for personal purposes and not in business…

But actually the message about server could be related issues broken because update was not working as it should. Maybe parts got already updated until package error with archiver was found while others remained on 8.6.8 version. Since there was nothing mentioned in changelog about changed ldap things so I didn’t searched for this deeper. I simply downgraded everything and placed a hold on all kopano packages that come with version 8.6.8.

Andreas

Well, we use Mattermost internally, so the support guys are just a “@channel” away ;-)