Issue syncing in iPhone

Hi!

I’m getting this error in 2.4.4… :

17/11/2018 17:57:25 [32290] [ INFO] [xxxx@xxxxxx.xx] cmd=‘Sync’ memory=‘21.67 MiB/4.00 MiB’ time=‘5.62s’ devType=‘iPhone’ devId=‘ijsb9mu5cl36b7phdblhfg4g1c’ getUser=‘xxxx@xxxxxx.xx’ from=‘xxx.xxx.xxx.xxx’ idle=‘0s’ version=‘2.4.4+0’ method=‘POST’ httpcode=‘200’
17/11/2018 17:57:31 [27044] [ INFO] [xxxx@xxxxxx.xx] ExportChangesDiff->InitializeExporter(): Found ‘7541’ changes for ‘1afd05d0’
17/11/2018 17:57:31 [27044] [WARN] [xxxx@xxxxxx.xx] Mobile loop detected! Messages sent to the mobile will be restricted to 2 items in order to identify the conflict
17/11/2018 17:57:31 [27044] [WARN] [xxxx@xxxxxx.xx] /usr/share/z-push/include/mimeDecode.php:865 iconv(): Detected an illegal character in input string (8)
17/11/2018 17:57:31 [27044] [WARN] [xxxx@xxxxxx.xx] /usr/share/z-push/include/mimeDecode.php:865 iconv(): Detected an illegal character in input string (8)
17/11/2018 17:57:31 [27044] [ERROR] [xxxx@xxxxxx.xx] Ignored broken message (SyncMail). Reason: ‘2’ Folderid: ‘i/1afd05d0’ message id ‘5813’
17/11/2018 17:57:32 [27044] [ INFO] [xxxx@xxxxxx.xx] cmd=‘Sync’ memory=‘21.67 MiB/2.00 MiB’ time=‘6.26s’ devType=‘iPhone’ devId='ijsb9mu5cl36b7phdblhfg4g

Then it stops syncing the folder…

Could a possible workaround exist?. I’m syncing all mail (not limited to some date…).

Please tell me if you needed some debug or similar…

Best regards,

it’s last iOS…

for the zpush devs to check the error please use debug LOGLEVEL_WBXMLSTAC then post the information

Hi egoitzau,

it looks like one of the emails in the inbox is broken and therefore the sync doesn’t work. You could try to limit sync window to see if it works and it’s one of the older emails.

@killmasta93 said in Issue syncing in iPhone:

for the zpush devs to check the error please use debug LOGLEVEL_WBXMLSTAC then post the information

  1. There’s no such log level.
  2. LOGLEVEL_WBXML is enough in most cases, unless we explicitly ask for LOGLEVEL_WBXMLSTACK.

Manfred