After a fresh installation of Kopano / Univention, kopano-server not able to start



  • Direct after a fresh installation of Kopano, I’m not able to start kopano-core. The error message is “Unable to bind to port 236”. The system shows that kopano-core is already running on this port.

    root@kopano:/etc/kopano# kopano-server start
    Sun Nov 11 21:55:06 2018: [=======] Starting kopano-server version 8.6.2 (pid 24295)
    Sun Nov 11 21:55:06 2018: [crit ] Unable to bind to port 236: Die Adresse wird bereits verwendet. This is usually caused by another process (most likely another server) already using this port. This program will terminate now.
    Beendet

    A netstat shows the following result:

    root@kopano:/etc/kopano# netstat -npl |grep 236
    tcp 0 0 0.0.0.0:236 0.0.0.0:* LISTEN 30606/kopano-server

    root@kopano:/etc/kopano# netstat -npl |grep 237
    tcp 0 0 0.0.0.0:237 0.0.0.0:* LISTEN 30606/kopano-server

    root@kopano:/etc/kopano# netstat -npl |grep kopano
    tcp 0 0 0.0.0.0:236 0.0.0.0:* LISTEN 30606/kopano-server
    tcp 0 0 0.0.0.0:237 0.0.0.0:* LISTEN 30606/kopano-server
    tcp6 0 0 :::110 :::* LISTEN 30738/kopano-gatewa
    tcp6 0 0 :::143 :::* LISTEN 30738/kopano-gatewa
    tcp6 0 0 :::8080 :::* LISTEN 30712/kopano-ical
    tcp6 0 0 :::2003 :::* LISTEN 30763/kopano-dagent
    tcp6 0 0 :::8443 :::* LISTEN 30712/kopano-ical
    tcp6 0 0 :::993 :::* LISTEN 30738/kopano-gatewa
    tcp6 0 0 :::995 :::* LISTEN 30738/kopano-gatewa
    unix 2 [ ACC ] STREAM HÃRT 138098 30798/python2 /var/run/kopano/search.sock
    unix 2 [ ACC ] STREAM HÃRT 136688 30606/kopano-server /var/run/kopano/prio.sock
    unix 2 [ ACC ] STREAM HÃRT 136690 30606/kopano-server /var/run/kopano/server.sock

    This happens with a fresh iso image installation and as well with the import to virtualbox. I downloaded yesterday both versions. A kopano-server stop and start or a reboot didn’t help.

    Thanks for your help in advance


  • Kopano

    @dondu1960 said in After a fresh installation of Kopano / Univention, kopano-server not able to start:

    root@kopano:/etc/kopano# kopano-server start

    Why do you want to start the server this way? It’s already started via systemd and does not need to be manually started.



  • This post is deleted!

  • Kopano

    Why do you keep deleting your replies @dondu1960 ?



  • It was only an empty answer which I removed


  • Kopano

    I do see deleted (and edited posts) and I know this is not true ;-)



  • Is was the same message as the response before “Ok, thanks it was a mistake by me” and im missed the second part of the message



  • I find out why I got the mapi error during login in the webapp. For all of my created users no store was automatically created, too.

    root@kopano:~# kopano-cli --list-users
    User list for Default (3):
    User Full Name Homeserver Store

        Brigitte          Brigitte                  kopano
        SYSTEM       SYSTEM              kopano        8962FFEFFB7B4D639BC5967C4BB58234
        Uwe               Uwe                     kopano
    

    After adding the store manually the logon is working successfully.

    root@kopano:~# kopano-cli -u uwe --create-store
    root@kopano:~# kopano-cli -u brigitte --create-store
    root@kopano:~# kopano-cli --list-users
    User list for Default (3):
    User Full Name Homeserver Store

        Brigitte          Brigitte                 kopano        227160E136164EC7835FEAAA20E622CC
        SYSTEM      SYSTEM              kopano        8962FFEFFB7B4D639BC5967C4BB58234
        Uwe              Uwe                     kopano        4183C8086C584490A54C2E816AA5E840

Log in to reply