Fonts change after mail is send



  • @mcdaniels
    Hi, did you solve the problem? We have the same issue. We use also html-signatures created by example_wrapper.sh.
    First i thought it was a joke when an employee reported this to mee. Sometimes this happens even if you write a text and use a comma.
    This looks indeed not realy professional. I had already a lot not so nice discussions with my colleagues.
    I suspected a problem with the nightly builds from the community, but the commercial downloads produce the same issue.
    @externa1
    For me it did not solve the problem.

    Best regards.



  • @sturzhelmut: for me https://forum.kopano.io/topic/1653/request-for-feedback-minimal-tinymce-implementation solves the problem concerning the different fonts.

    BUT: There is another problem then, that if you write a mail with kopano and use a blank line e.g. a paragraph with an additional return (enter), this return is removed in Outlook.

    so, if you send:

    TEST

    TEST

    it arrives in Outlook like this:
    TEST
    TEST

    What exactly is your problem? Have you cloned the git and use the minimal-tiny editor?



  • @mcdaniels
    You are right. The minimal-tiny editor solves the problems with the different fonts. My mistake.
    BUT: That is not realy a solution. Some of our employees have conversations with lots of paragraphs and they make comments in different colours. We use this not only for internal communication, but our clients expect these coloured anwers too. Removing the options of formatting html would kick off a shitstorm.



  • @sturzhelmut
    ok, I see your problem. We don’t “color” our mails, so it is not a big problem that there are very few formatting options. The problem with the “missing return” is getting bigger and bigger here.

    It is never easy to switch to another product, when all users only know one mailclient. Some missing features / bugs don’t make it better, but DeskApp is a “very young” software. I am sure it will reach most requirements in the future.



  • Hi,
    are there any news for this issue?
    We still have some mails which have this formatting problems. It happens only a few times now and in most cases this happens if you answer an incoming mail. This looks terrible and some of our customers make already jokes about it.
    As i wrote above the minimal-tiny editor is not a solution for us.

    Best regards,

    Deskapp: 2.1.9
    Webapp: 3.5.1
    Server: 8.6.9.0
    on SLES12



  • same issue here. Have some employees reporting that their message font was changed. Not completely, just some lines. I checked that and indeed some lines have other font or/and other size.

    What is the culprit and how can we fix that?


  • Kopano

    @micro the already mentioned reduced editor is now available as a packaged solution. As far as I understood this is meant to solve these issues.

    See https://forum.kopano.io/topic/2186/new-html-editor-available-minimal-tinymce for more information.



  • Hello Felix,

    thank you for this helpful information. I have updated my Debian apt repo and installed the package:

    kopano-webapp-plugin-htmleditor-minimal-tinymce 1.0.0.9+1.1

    after re-login in WebApp I can select that TinyMCE editor which works fine at first look. The only hurdle I need to master is --> how can I have this editor enabled for all users by default ? didn’t find any directive in webapps’ config.php

    any clue?



  • Although I still have the question, how I can enforce the use of MinimalTinyMCEeditor by default for all users I just had to face the issue on my own:

    I did send a message by using Kopano-DeskApp. My setting was to use that MinimalTinyMCEeditor. I was definitely using it because during commposing the message I was not able to change font or size. I did copy&paste a one single line from a linux command line from a /var/log/mail.log file and pasted it to my message. Then I applied the “italic” font to this line. In my message I had some words marked as “bold” and some others as “italic” or “bold+italic”. The message looked fine before I did send it.

    After sending the message I went to my “Sent Mails” folder and realized that my message looked weird:

    • missing line wraps
    • different font on different lines
    • different size on different lines

    Simply said ==> the same issue as I had reported by some of our employees that worked with the default TinyMCEeditor (not the SimpleTinyMCEeditor). This time I faced this issue on my own so I can be sure it’s not an employee user error.

    Any help appreciated.


  • Kopano

    sorry I cannot say anything about this, since I am not that deep in the webapp stack. If you are depending on quick answers i can only recommend to get in direct contact with our support.


Log in to reply