Z-Push 2.4.5 beta1 released

Hello,

we have just released Z-Push 2.4.5 beta1 (tag 2.4.5.beta1 commit 3a582d445f9df7000b360a91295af00b445bba0d - please note that there was an update after the tagging and current version of the repository is 2.4.5 beta1+2).

This is a maintenance release with some bugfixes and improvements.

Email categories would disappear in Outlook when marking email as read or unread on another client. This issue has been fixed however there might be increased server load as Z-Push now opens the email to load the categories.

We made some changes to Z-Push packaging in order to fix dependencies on Debian 9, logrotate on RHEL 6 and improve performance for installations which use nginx as the webserver.

Thanks to Nicolas who provided a path to reproduce an issue GAL search bug and a solution how to fix it.

Private items are no longer stripped in own calendar when it’s configured as shared folder in Z-Push config.

Editing recurring tasks on mobile clients now shouldn’t break synchronisation.

Install Z-Push 2.4.5 beta1 from the pre-final repositories (recommended) Z-Push Wiki.

Tickets in Z-Push 2.4.5 beta1

Bug
[ZP-1225] - GAL search returns username as email address
[ZP-1447] - php-mbstring is needed on Debian 9 as well
[ZP-1449] - Private items stripped in own calendar when calendar folder is also configured as share
[ZP-1452] - Fix logrotate for RHEL6
[ZP-1455] - nginx: change location from regex match to prefix match
[ZP-1456] - Categories are lost when marking email read/unread on shared account
[ZP-1457] - FirstDayOfWeek missing for recurring tasks

Code changes since Z-Push 2.4.4: https://stash.z-hub.io/projects/ZP/repos/z-push/compare/diff?targetBranch=refs%2Ftags%2F2.4.4&sourceBranch=refs%2Ftags%2F2.4.5.beta1

Please share your experiences (positive and negative) and give feedback!

Greetings,
Manfred

Update 30.10.

We added one more improvement for RHEL based systems. Using RHEL with Remi PHP 7.x packages and SQL state machine should work now.

Improvement
[ZP-1438] - RHEL 7 packages are incompatible with Remi PHP 7.x packages

Current version of the pre-final repository is 2.4.5 beta1+4.

Manfred

Update 31.10

Fix for ZP-1438 which wasn’t installing correctly.

Improvement
[ZP-1438] - RHEL 7 packages are incompatible with Remi PHP 7.x packages

Current version of the pre-final repository is 2.4.5 beta1+6.

Manfred

Locked