Zpush issue with only MAC



  • Hi,
    I was wondering if anyone else has had issue with Mac devices only? Currently running zpush 2.4.4 i can get exchange working on any device beside mac. I checked the log and get this
    I have configured also autodiscover.mydomain.com. This is my NGINX
    any ideas?

    Thank you

    server {
                                   server_name mail.mydomain.com; 
                                   root    /var/www/zpush/src;
                                   access_log /var/www/rainloop/logs/access.log;
                                   error_log /var/www/rainloop/logs/error.log;
                                   index index.php;
                               
                                   location / {
                                       try_files $uri /index.php?$query_string;
                                   }
                               
                                   location ~ \.php$ {
                                       fastcgi_index index.php;
                                       fastcgi_param HTTPS on;
                                       fastcgi_split_path_info ^(.+\.php)(.*)$;
                                       fastcgi_keep_conn on;
                                       include /etc/nginx/fastcgi_params;
                                       fastcgi_pass unix:/var/run/php5-fpm.sock;
                                       fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                                       fastcgi_param   REQUEST_URI $1;
                                       fastcgi_param   PHP_FLAG "magic_quotes_gpc=off \n register_globals=off \n magic_quotes_runtime=off \n short_open_tag=on";
                                       fastcgi_param   PHP_VALUE "post_max_size=20M \n upload_max_filesize=20M \n max_execution_time=3660";
                                       fastcgi_param   HTTP_PROXY ""; # Mitigate https://httpoxy.org/ vulnerabilities
                                       fastcgi_read_timeout 3660; # Z-Push Ping might run 3600s, but to be safe
    
                                                                  
                                   }
                               
                                   location ~ /\.ht {
                                       deny all;
                                   }
                               
                                   location ^~ /data {
                                     deny all;
                                   }
                                   
                                   location /Microsoft-Server-ActiveSync {
                                    rewrite ^(.*)$  /index.php last;
                                   }
    
    
                               
                                   listen 443 ssl; # managed by Certbot
        ssl_certificate /etc/letsencrypt/live/mail.mydomain.com/fullchain.pem; # managed by Certbot
        ssl_certificate_key /etc/letsencrypt/live/mail.mydomain.com/privkey.pem; # managed by Certbot
                                   include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
                                   ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
                                   ssl_trusted_certificate /etc/letsencrypt/live/mail.mydomain.com/chain.pem; # managed by Certbot
                                   ssl_stapling on; # managed by Certbot
                                   ssl_stapling_verify on; # managed by Certbot
                               
                               
    }
        
           server {
    
                       server_name autodiscover.mydomain.com; 
                                   listen 443 ssl; # managed by Certbot
                                  ssl_certificate /etc/letsencrypt/live/autodiscover.mydomain.com/fullchain.pem; # managed by Certbot
                                  ssl_certificate_key /etc/letsencrypt/live/autodiscover.mydomain.com/privkey.pem; # managed by Certbot
                                   include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
                                   ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
                                   ssl_trusted_certificate /etc/letsencrypt/live/autodiscover.mydomain.com/chain.pem; # managed by Certbot
                                  ssl_stapling on; # managed by Certbot
                                   ssl_stapling_verify on; # managed by Certbot
    
    				access_log  /var/log/z-push/autodiscover.log;
                                  error_log /var/log/z-push/autodiscover-error.log;
    
    
                                    root   /var/www/zpush/src/;
                                   index autodiscover.php;
                                  
                               error_page 405 =200 $uri;
    
                       location / {
                   if ($uri !~ ^/autodiscover/autodiscover\.php) {
                rewrite ^ /autodiscover/autodiscover.php;
               }
            }
    
        location ~ \.php$ {
    #       fastcgi_split_path_info ^(.+\.php)(/.+)$;
            fastcgi_pass unix:/var/run/php5-fpm.sock;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include /etc/nginx/fastcgi_params;
        }
    
    
    
                             
    
      
    
                       }
    
     14/10/2018 17:28:50 [ 9792] [FATAL] [sistemas] FatalException: Requested the Z-Push URL without the required GET parameters - code: 0 - file: /var/www/zpush/src/index.php:71
    14/10/2018 17:28:50 [ 9792] [ INFO] [sistemas] User-agent: 'Mac OS X/10.10.5 (14F27); ExchangeWebServices/5.0 (213); Mail/8.2 (2104)'
    14/10/2018 17:28:50 [ 9792] [FATAL] [sistemas] Exception: (FatalException) - Requested the Z-Push URL without the required GET parameters
    14/10/2018 17:28:50 [ 9792] [ INFO] [sistemas] cmd='' memory='1.74 MiB/2.00 MiB' time='0.01s' devType='' devId='' getUser='sistemas' from='200.xx.xx.xx' idle='0s' version='GIT' method='POST' httpcode='500'```

  • Kopano

    @killmasta93 said in Zpush issue with only MAC:

    i can get exchange working on any device beside mac

    If you are talking about Apple iCal, Mail & co., then these programs do not support Activesync, but EWS. Hence they won’t connect to Z-Push



  • Thanks for the reply, Ooooo did not know so is there a way to put then exchange on the mac?

    SOLVED: The only way that works for anyone who needs, is configure the account IMAP then configure each account Carddav and Caldav and should work.



  • There is no carddav in Kopano


  • Kopano

    Hi cpzengel,

    @cpzengel said in Zpush issue with only MAC:

    There is no carddav in Kopano

    That’s not true: https://forum.kopano.io/topic/1341/request-for-feedback-new-caldav-and-carddav-implementation-for-kopano.

    But if you want to sync your Kopano data to a mobile device, I suggest to use Z-Push and the Kopano backend.

    Manfred



  • that simply is not finished yet and did not work


  • Kopano

    @cpzengel said in Zpush issue with only MAC:

    and did not work

    If you had problems getting it to work, then I would recommend to post a report in the already mentioned topic. Only if you report issues these can be looked at and eventually be fixed.

    @cpzengel said in Zpush issue with only MAC:

    There is no carddav in Kopano

    If you look at the webserver config and post history of the original topic creator, then you will see that he is not using Kopano at all, therefore your statement if quite off topic.


Log in to reply