ubuntu 18.04 upgrade. Issues installing z-push 2.4.4

Hello,
I’ve upgraded from Ubuntu server 16.04 to 18.04 and cannot install z-push.

I was running before z-push 2.3 (manual installation) but without php 7.x support I need to use the latest z-push.
I’ve read the wiki and searched the forum but couldn’t find any solution to my issue (some issues were similar but tried it and it didn’t help)

So I first created the z-push.list added the repo and sent

wget -qO - http://repo.z-hub.io/z-push:/final/Ubuntu_18.04/Release.key | sudo apt-key add -

When trying to run sudo apt-get install z-push-kopano z-push-config-apache I received following error

The following packages have unmet dependencies:
 z-push-kopano : Depends: z-push-backend-kopano (= 2.4.4+0-0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages. 

So I tried sudo apt-get install z-push-backend-kopano z-push-config-apache

But then I receive

The following packages have unmet dependencies:
 z-push-backend-kopano : Depends: php7-mapi but it is not installable or
                                  php5-mapi but it is not installable
E: Unable to correct problems, you have held broken packages.

php-map is correctly installed

# apt install php-mapi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php-mapi is already the newest version (8.5.5-0ubuntu1).

Thanks,
Nuno

Hi @nunor ,

the z-push packages are designed and tested against the official Kopano packages, but seeing that your version is 8.5.5-0ubuntu1 you seem to be running the packages provided by the Ubuntu repositories.

If my memory is correct there should also be a z-push in the Ubuntu repositories. I would expect that this one works out of the box.

If you still want to use the official z-push packages, then to fulfil app dependencies, you probably need to upgrade to the official kopano packages as well.

Hi @fbartels ,

Thanks for the quick reply. I checked and u-push is indeed in the Ubuntu repositories but only version 2.3.8 (https://packages.ubuntu.com/bionic/z-push) which will not work with php 7.2