I’ve upgraded from Ubuntu server 16.04 to 18.04 and cannot install z-push.
I was running before z-push 2.3 (manual installation) but without php 7.x support I need to use the latest z-push.
I’ve read the wiki and searched the forum but couldn’t find any solution to my issue (some issues were similar but tried it and it didn’t help)
So I first created the z-push.list added the repo and sent
wget -qO - http://repo.z-hub.io/z-push:/final/Ubuntu_18.04/Release.key | sudo apt-key add -
When trying to run
sudo apt-get install z-push-kopano z-push-config-apache I received following error
The following packages have unmet dependencies: z-push-kopano : Depends: z-push-backend-kopano (= 2.4.4+0-0) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
So I tried
sudo apt-get install z-push-backend-kopano z-push-config-apache
But then I receive
The following packages have unmet dependencies: z-push-backend-kopano : Depends: php7-mapi but it is not installable or php5-mapi but it is not installable E: Unable to correct problems, you have held broken packages.
php-map is correctly installed
# apt install php-mapi Reading package lists... Done Building dependency tree Reading state information... Done php-mapi is already the newest version (8.5.5-0ubuntu1).