Manual ZCP to Kopano migration



  • Hi
    I am testing manual migration.
    In the documentation
    3.3.2. Removal of ZCP packages there is a command for Debian to remove ZCP packages :

    " dpkg -l | egrep ‘(mapi|gsoap|ical|vmime|zarafa)’ | awk ‘{ print $2 }’ | xargs apt-get remove "

    I tried this but the command was not successful . I saw the package list at the screen.

    It seems to me that the egrep command with the pattern “ical” selects some wrong packages ( not ZARAFA) from the
    list generated by the dpkg -l command … ( ical is in the package description part)
    Is the command ok ? Am I doing something wrong?

    regards bskoeln


  • Kopano

    @bskoeln yes, I think you’re right. I must say I never tried the manual personally but looking at the query I personally would expect it to look like the following:

    dpkg -l | egrep ‘(mapi|gsoap|libical|vmime|zarafa)’ | awk ‘{ print $2 }’ | xargs apt-get remove
    


  • Hello bskoeln,

    I recommend a clean installation! Save you problems later.

    Sinux.



  • Hallo
    I think Sinux is right. I continued testing the manual migration -with the “new” command- removing zarafa packages and then installing the new Kopano packages.
    After connecting the server to the existing zarafa database the server starts. But the first

    kopano-admin -l
    

    shows this errror

    Unable to load libzarafaclient.so : /usr/lib/kopano/libzarafaclient.so: kann die Shared-Object-Datei nicht öffnen : Datei oder Verzeichnis nicht gefunden     Unable to open Admin session : not found 
    

    And a connection to the server via webapp shows a

    " Unknown MAPI Error: MAPI_E_NOT_FOUND" in the login screen.

    bskoeln



  • You may need this???
    https://forums.zarafa.com/showthread.php?3777-Solved-Unknown-MAPI-Error-MAPI_E_NOT_FOUND

    The best Way is a backup from DB, /etc & /data Folder and a fresh Installation.
    Recover from /etc/postfix, fetchmail, ssl (Zertifikate) to new System.
    Don’t forget the User Rights!!!
    User to reinitialize with kopano-admin, search …
    My Migration from Yaffas to Kopano (User on DB) was not simple ;)
    This Doku is your Friend, https://documentation.kopano.io/kopanocore_administrator_manual/installing.html

    Please fill your Signature
    thx
    Sinux



  • hi bskoeln

    i had the same issue after migrating from zarafa 7.2.1 to kopano. the solution in my case was to remove file /etc/mapi/zarafa.inf.

    so based on this documentation: https://documentation.kopano.io/kopano_migration_manual/zcp_migration.html

    1. remove zarafa packages:
    dpkg -l | egrep '(mapi|gsoap|libical|vmime|zarafa)' | awk '{ print $2 }' | xargs apt-get remove
    
    1. remove additional zarafa packages:
    apt-get remove packages installed with zarafa: apt-get remove -y -q python-itsdangerous-doc python-itsdangerous python3-itsdangerous libzcp-common-util0 libzcp-common-ssl0 libzcp-common-service0 libunwind8-dev libunwind8-dbg libunwind8
    
    1. remove zarafa.inf file:
    rm /etc/mapi/zarafa.inf
    
    1. proceed with installation of kopano packages.

    hope this helps someone.

    regards,
    daniel


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.