Kopano-server-packages on new empty Ubuntu 18.04 not installing

Pulling my hair out to try to get supported final version of kopano installed on a new Ubuntu 18.04 machine.

First there seems to be a kopano version available in the universe repo, which is standard in the sources.list file in Ubuntu 18.04.
Uncommenting resolved that.
But after putting in a kopano.list i get:

root@kopano-test:~# apt-get install kopano-server-packages
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kopano-server-packages : Depends: kopano-search (= 8.6.7.0-0+16.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@kopano-test:~#

I also tried to download a tar with all the deb-files, but there I see different versions of the same program:

-rw-r--r-- 1 25122 users    59096 Apr  9 13:46 kopano-lang_8.5.6.1-0+13.1_all.deb
-rw-r--r-- 1 25122 users    60684 Aug 14 14:40 kopano-lang_8.6.7.0-0+16.1_all.deb
-rw-r--r-- 1 25122 users    73132 Aug 14 14:40 kopano-migration-imap_8.6.7.0-0+16.1_amd64.deb
-rw-r--r-- 1 25122 users    43388 Aug 14 14:40 kopano-migration-pst_8.6.7.0-0+16.1_amd64.deb
-rw-r--r-- 1 25122 users    41580 Aug 14 14:40 kopano-monitor_8.6.7.0-0+16.1_amd64.deb
-rw-r--r-- 1 25122 users    17096 Aug 14 14:40 kopano-presence_8.6.7.0-0+16.1_amd64.deb
-rw-r--r-- 1 25122 users    32208 Aug 14 14:40 kopano-search_8.6.7.0-0+16.1_amd64.deb
-rw-r--r-- 1 25122 users   273392 Aug 14 14:40 kopano-server_8.6.7.0-0+16.1_amd64.deb
-rw-r--r-- 1 25122 users    12376 Apr  9 13:46 kopano-server-packages_8.5.6.1-0+13.1_all.deb
-rw-r--r-- 1 25122 users    12376 Aug 14 14:40 kopano-server-packages_8.6.7.0-0+16.1_all.deb

Seems to me that that is not intentional, or is it??

How to proceed?

TIA
Leen

@ldb1619 what is the output if you run apt install kopano-search?

@fbartels

root@kopano-test:~# apt install kopano-search
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kopano-search : Depends: catdoc but it is not installable
                 Depends: xapian-tools but it is not installable
E: Unable to correct problems, you have held broken packages.
root@kopano-test:~#

Gtz
Leen

To be complete:

root@kopano-test:~# apt install xapian-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package xapian-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'xapian-tools' has no installation candidate
root@kopano-test:~# apt install catdoc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package catdoc is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'catdoc' has no installation candidate
root@kopano-test:~#

Could having me uncomment the universe repos of Ubuntu 18.04 be of importance?

Gtz
Leen

Maybe yes, xapian-tools and catdoc both seem to be in universe.

How to solve?

Gtz
Leen

@ldb1619 said in Kopano-server-packages on new empty Ubuntu 18.04 not installing:

How to solve?

Just reenable the universe repos. You probably did a apt install kopano which the package manager tried to fulfil with the Ubuntu packages, instead you should have done apt install kopano-server-packages.

Since our packages generally have higher versions there should be no problem in having universe enabled anyways.

@fbartels

Must have been the weekend…
In the meantime I installed, had to set root pw on mysql (this way:

https://linuxconfig.org/how-to-reset-root-mysql-password-on-ubuntu-18-04-bionic-beaver-linux
).
First start of kopano says no database kopano present, but looking into mysql it was there, restarting kopano-server seems to be ok now.

Going further configuring, thanks so far.

Gtz
Leen

@ldb1619 said in Kopano-server-packages on new empty Ubuntu 18.04 not installing:

First start of kopano says no database kopano present

yes, in the default logging the server only logs that he could not find the database, with a higher logging you would have seen that he then proceeds to create the database and tables.

Hai, try the following.

apt-cache policy kopano-server kopano-search

And post the outpot.

if you use a local repo ( file repo ) ,
try this :

deb [trusted=yes]   …

but lets start with the policy info.

https://packages.ubuntu.com/search?keywords=xapian-tools
Ok, i can explain the problem here is.

The Ubuntu packages (same for the Debian packages) have some other packages then the kopona repo ( and community packages ).
Due to the differences here you have this.

You might need to set a preferences file also for the kopano packages and give the version you preffered a higher pinning.

read : https://www.howtoforge.com/a-short-introduction-to-apt-pinning
That is a good example.