[solved]Webapp language of folders like Inbox

Hello,
I have the problem under ubuntu16.04 that I can’t get the folder language in the webapp set up in German.
I don’t want to change anything afterwards, but basically have the folder language in German.

I’ve read a lot of different pages about this topic.
Unfortunately without success.
I can change the environment of the web client to German, but the folders like Inbox etc. remain set to English.

I have already done the localization of the operating system.
Here everything is set to German.

https://askubuntu.com/questions/978615/how-do-i-change-the-system-language-to-german-in-ubuntu-16-04-via-terminal

#  File generated by update-locale
LANG=de_DE.UTF-8
LC_MESSAGES=
LC_COLLATE=
LANGUAGE=de_DE:de
LC_CTYPE=

One said the language will be /etc/kopano/userscripts/createuser.d
unfortunately there is no file there and I haven’t found out what I have to write into it (I can certainly do some research if this is the right way to do it).

On my Debian 9.x Stretch I didn’t have to adjust anything, because after the German installation of the server every store and user was automatically in German.

The documentary says here:
https://documentation.kopano.io/kopanocore_administrator_manual/configure_kc_components.html
Change something /etc/default/kopano.
The same again, this file does not exist.
And it doesn’t explain what’s in the file, just that you have to change an entry.

Someone has an idea?

EDIT:
I created the file /etc/default/kopano with

KOPANO_USERSCRIPT_LOCALE=de_DE.UTF-8

but didnt help.

/etc/default/kopano is only still used with the release builds, for the nightly packages it has been deprecated.

The new way of setting this is by specifying the desired locale in admin.cfg: https://stash.kopano.io/projects/KC/repos/kopanocore/browse/installer/linux/admin.cfg#1-3

PS: there are also scripts bundled that allow to change the locale after the store has already been created.

@fbartels

As i reinstalled a server with Univention UCS4.3 and got the problem that new mailboxes do not get the right language - but there is no more a /etc/default/kopano file and i did not find a admin.cfg file (where should this file stay?)

rg
Christian

@externa1 which version of core do you have installed. its true that this feature will also reach the official releases, but only in 8.6.8 which is at this moment only in pre-final.

as for the admin.cfg, if it does not exist you can just create it in /etc/kopano.

@fbartels

I had installed what came with UCS4.3 APP installation (8.6.x)

rg
Christian

@externa1 but that is 8.6.2 and there /etc/default/kopano is still existant

@fbartels

I checked a second install (UCS4.3 plain app install) - and there also the /etc/default/kopano file is not existent

rg
Christian

Hi @externa1 ,

ah I think I know what goes wrong on your system. since you are on 8.6.2 (or 8.6.7 if you have enabled the Kopano repos) your installation will still use the values configured in /etc/default/kopano. But as the config file listener does not update files that do not yet exist these values have not been set in your configuration.

In other words your system would use /etc/default/kopano, but the file is not installed by default since 8.6.0. and since its not installed by default its also not properly configured.

What you need to do is to manually create the file once (e.g. with touch /etc/default/kopano) and then you can call while read ucrv; do ucr set "$ucrv"="$(ucr get $ucrv)"; done < <(ucr search --brief kopano/default | awk -F : '{print $1}') to fill the file with the settings from the ucr.

I’ve updated the integration package to properly handle this in the future https://stash.z-hub.io/projects/K4U/repos/kopano4ucs/commits/9c8fb0eb2e14ccde1c69063319f89160b3380a49

Hi Felix, thanks for your answer.

I think it’s a pity that it’s not in the documentation, or I missed something here?
If it is obsolete, someone should at least point it out.
On the other hand, I don’t want to bitch about, the documentation is really good…
I was able to solve it by searching here in the forum by
’ kopano-localize-folders -u <myuser> --lang de_DE.UTF-8 ’
Thanks for the hint with the /etc/kopano/admin.cfg

@taumeister said in [solved]Webapp language of folders like Inbox:

If it is obsolete, someone should at least point it out.

I’ve already made a note about this for later. the “problem” is that the documentation focuses on released products and this change so far has only been on the nightly builds.

What is the correct syntax for the locale in admin.cfg ?

default_store_locale = de_DE
default_store_locale = “de_DE”
default_store_locale = de_DE.UTF-8
default_store_locale = “de_DE.UTF-8”

Hi,

admin manual: https://documentation.kopano.io/kopanocore_administrator_manual/configure_kc_components.html#configure-language-for-store-creation
states: “for example nl_NL.UTF-8 or fr_FR.UTF-8.”
I use this line: "default_store_locale = de_DE.UTF-8 "and it works.