Services not starting automatically after reboot

Hi folks,
I just recognizen on a new install that none of the kopano-services (search, server, spooler) is starting automatically.

● kopano-server.service - Kopano Groupware Core Storage Server
   Loaded: loaded (/lib/systemd/system/kopano-server.service; disabled; vendor p
reset: enabled)
   Active: inactive (dead)

This is the same for all other services.

If I start them manually, all is working.

Do you have any clue, why this is happening?

@mcdaniels

starting is disabled. Enable it by

# systemctl enable kopano-server

Hi tjoen,

do you know, whether this is by design, or is there a mistake in the (my) configuration?

Thanks!

Common sense. If you install a program then it doesn’t mean that you want it always started on startup.

As far as I noticed, that was not the case in earlier versions of kopano. At least my older installation did not do that.

Thanks for your input! :)

@tjoen said in Services not starting automatically after reboot:

Common sense. If you install a program then it doesn’t mean that you want it always started on startup.

Yes, but Debian lacks that sense (and derivates inherit it).