kopano-gateway don't listen on 993

Hi,

Version: 8.6.81.397-0+69.1

gateway.cfg

coredump_enabled<------>= no.                                                                                                     
                                                                                                                                  
log_level = 6                                                                                                                     
imap_listen<---><------>= *:143                                                                                                   
imaps_listen<--><------>= *:993                                                                                                   
                                                                                                                                  
#letsencrypt                                                                                                                      
ssl_private_key_file<-->= /etc/kopano/ssl/privkey.pem                                                                             
ssl_certificate_file<-->= /etc/kopano/ssl/cert.pem                                                                                
ssl_protocols<-><------>= !SSLv3                                                                                                  
                           

But

netstat -tulpen | grep -i kopano-gate
tcp6       0      0 :::110                  :::*                    LISTEN      0          559748     10556/kopano-gatewa
tcp6       0      0 :::143                  :::*                    LISTEN      0          559753     10556/kopano-gatewa

This must changed somwere between Ver.: 8.6.81.228-0+37.1 and now.
I now reinstalled 8.6.81.228-0+37.1 and it’s working again.

Greets
Thomas

Hi,

but
imaps_listen = *:993
ist set in gateway.cfg !

Greets
Thomas

If you read the first comment, you’ll learn that currently you need to set “socketspec=v2” in gateway.cfg to be able to work with these new style config options.

We have a PR open to completely remove the old options, which will also remove the socketspec requirement.

Hi,

thank’s socketspec=v2 in gateway.cfg was the solution

Greets
Thomas