Alot of issues after updating multi-tenant environment Kopano Servers

Hello together,

I’m running 3 Kopano Servers and 2 DCs in a multi-tenant environment with almost 2000 users.
I never had any problems with the system, untill I updated the servers from 8.5.x to 8.6.7.

Now I’m struggling with the errorlogs since over 3 weeks, but I have no clue what to do anymore. I tried to google every single error code, compared all configs etc. The errors affect alot of users, that’s why I really need to fix the issues.

The most users affecting issues right now:

  • zPush (Outlook2013 and Outlook2016 not syncing anymore -> tried different versions of KOE already -> Sync is starting -> Empty Folder structure gets synced -> Outlook disconnects)
  • Sending E-Mails to distribution groups with alot of members (Every distribution group with over 600 members fails -> very necessary for us, because we are using distrubution groups with over 1000 members in it)

Here some errors from my logs:

zPush Log:
[WARN] [#unknown] /usr/share/z-push/backend/kopano/mapiprovider.php:274 mapi_zarafa_getuser_by_name(): Unable to resolve the user: 8004010F (2)
[WARN] [#unknown] KopanoBackend->HasReadACLs(): error, no entryid resolved for x on store Resource id #x

dagent + Maillog:
[error ] [11146] Autoresponder failed
[error ] [22920] HRESULT ResolveServerToPath(IMAPISession*, const serverrecipients_t*, const string&, serverrecipients_t*): GetServerDetails failed: not found (8004010f)
[error ] [22920] HRESULT ProcessDeliveryToCompany(pym_plugin_intf*, IMAPISession*, LPADRBOOK, FILE*, const serverrecipients_t*, DeliveryArgs*): ResolveServerToPath failed: not found (8004010f)
[error ] [22920] HRESULT ProcessDeliveryToList(pym_plugin_intf*, IMAPISession*, FILE*, companyrecipients_t*, DeliveryArgs*): ProcessDeliveryToCompany failed: not found (8004010f)

-> Alot of E-Mails hanging in the queue, after flushing and observing mail or dagent log following happens:
(It shows for about 400-500 members that the E-Mail got removed, but after that it shows the error message over 1500 times in the log (2000+ users in the distribution group)

relay=127.0.0.1[127.0.0.1]:2003, delay=409338, delays=409338/0.09/0.06/0.25, dsn=4.2.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 450 4.2.0 mail@domain Mailbox temporarily unavailable (in reply to end of DATA command)

Gateway log:
[error ] [11339] Failed to read line: No route to host

Server log:
[warning] Authentication by plugin failed for user “”: Trying to authenticate failed: bneuamnn not found in LDAP; username = x
[warning] K-1515: Object not found unknown user ": x not found in LDAP
-> This warnings are tons of times in my server logs
[error ] ntlm_auth returned generic error “BH NT_STATUS_UNSUCCESSFUL NT_STATUS_UNSUCCESSFUL”
[error ] K-1215: unexpected id 2536/2268
[error ] Error while querying search on “file:///var/run/kopano/search.sock”, 0x80040115

If anyone has ANY hints, I would be VERY VERY thankful. Thank you all in advance.

Hi @ralphy,

from the version given above it sounds like you have a Kopano subscription and therefore access to our support. I would recommend to open up a support case with them, since this is a community forum and will probably not provide the level of service you need to resolve the issues on your installation.