Upgrade from core-8.6.80.1248 > core-8.6.81.171 gives reply issues with mime coding in to header

Hi Guys,

Yesterday we updated the core from 8.6.80.1248 to 8.6.81.171 now we have the following issue when we reply a mail. (tried with webapp versions webapp-3.4.14.1477 & webapp-3.4.21.1704)

In webapp the to mail adress shows the normal format user@domain.nl in postfix we are getting the following to header to==?utf-8?Q?=EF=BB=BFuser?=@domain.nl,
If we delete the original to mailaddress in webapp and put the same mailaddress. Then the e-mail goes out as normal.

New mail and reply on mails that we received after the update runs without any issues.

update with postfix header dump

named_attribute: dsn_orig_rcpt=rfc822;=?utf-8?Q?=EF=BB=BFuser?=@noreply.nl
original_recipient: =?utf-8?Q?=EF=BB=BFsent?=@noreply.nl
recipient: =?utf-8?Q?=EF=BB=BFsent?=@noreply.nl
*** MESSAGE CONTENTS 2/2F5FF3FBF5 ***
Received: from (localhost [127.0.0.1])
by portal.dest-domain.nl (Postfix) with ESMTP id 2F5FF3FBF5
for =?utf-8?Q?=EF=BB=BFsent?=@noreply.nl; Wed, 29 Aug 2018 12:22:41 +0200 (CEST)
Received: by (kopano-spooler) with MAPI; Wed, 29 Aug 2018 12:22:41
+0200
Subject: AW: Overzicht namen
From: =?utf-8?Q?dest_=7C_Dest_Name?= dest@dest-domain.nl
To: =?utf-8?Q?=EF=BB=BFFull Name?=
=?utf-8?Q?=EF=BB=BFsent?=@noreply.nl
Date: Wed, 29 Aug 2018 10:22:41 +0000
Mime-Version: 1.0

same reply on mail, removed to address and put it back in the reply mail

named_attribute: dsn_orig_rcpt=rfc822;sent@noreply.nl
original_recipient: sent@noreply.nl
recipient: sent@noreply.nl
*** MESSAGE CONTENTS 7/788A13FBFA ***
Received: from (localhost [127.0.0.1])
by (Postfix) with ESMTP id 788A13FBFA
for sent@noreply.nl; Wed, 29 Aug 2018 12:32:11 +0200 (CEST)
Received: by (kopano-spooler) with MAPI; Wed, 29 Aug 2018 12:32:11
+0200
Subject: AW: Overzicht namen
From: =?utf-8?Q?dest_=7C_Dest_Name?= user@noreply.nl
To: =?utf-8?Q?Robert-Jan_van_Baal?= sent@noreply.nl
Date: Wed, 29 Aug 2018 10:32:11 +0000
Mime-Version: 1.0

@rjvbaal said in Upgrade from core-8.6.80.1248 > core-8.6.81.171 gives reply issues with mime coding in to header:

In webapp the to mail adress shows the normal format user@domain.nl in postfix we are getting the following to header to==?utf-8?Q?=EF=BB=BFuser?=@domain.nl,
If we delete the original to mailaddress in webapp and put the same mailaddress. Then the e-mail goes out as normal.

I tried reproducing this issue, but it doesn’t appear on my test system.
The steps I took:

  1. Login as UserA and send an email from UserA to UserB.
  2. Upgrade the server to latest master (8.6.81.171-0+25.1)
  3. Login as UserB and reply to the email from UserA.

The email did not show any strange characters in the header.

Did you do anything else? Or are my steps wrong/incomplete? Let me know.

Hello Joost,

Thnx for your answer.

It only appears with external mail before the update.

I checked my packages with dpkg -l | grep 8.6 to check that all packages have been updated.

I noticed the following

libkcssl0 8.6.80.760-0+90.1
libkcsync0 8.6.80.760-0+90.1
libkcmapi0 8.6.80.760-0+90.1

These packages are from the update before the last update, i think the core don’t use these packages anymore?

@rjvbaal said in Upgrade from core-8.6.80.1248 > core-8.6.81.171 gives reply issues with mime coding in to header:]

It only appears with external mail before the update.

I’ll check this out.

i think the core don’t use these packages anymore?

Correct, they should get removed when running autoremove:

~#: apt-get autoremove