[Solved] Unable to connect to Z-Push Server

Hi,

I just installed kopano on a debian stretch system with apache and mysql.
Everything seems to work quite fine, but I can’t get z-push and kopano work together.
When logged in as admin user and entering settings in webapp I am getting:
Unable to connect to Z-Push Server. Could not connect to host.

Version Information in webapp shows me:
WebApp: 3.4.17.1642+934.1
Kopano Core: 8.6.80
Z-Push: version not available

z-push-top shows:
Z-Push: 2.4.4+0-0 PHP-MAPI: 8.6.80

I could not find any errors or something in the logfiles. z-push.log is empty.
Tried to follow the install instructions on the kopano site, but something obviously went wrong.
I do not know, which files could be useful for diagnostics.
Help would be very appreciated!

Thanks in advance,
Otto

Hi @otto001,

@otto001 said in Unable to connect to Z-Push Server:

When logged in as admin user and entering settings in webapp

this makes it sound like your problem is more with the WebApp mdm plugin, than Z-Push itself. is that correct?

Can you otherwise sync phones? (the mdm plugin is something really optional)

ps: if the first thing is the case, then I’d move your thread over to the webapp plugin section.

@fbartels no, sync is also not working. phones can not connect…
I would not really need the mdm plugin, but I WOULD need z-push and thought the error could be a help.

If I should provide any more info, please let me know.

Then the first thing you should check is if you can open http://your-server/Microsoft-Active-Sync in your browser. You should get a login prompt and after logging in should see a message GET not supported (which is expected since its not meant for the browser).

if that works then you need to check if the same works when using the browser on your phone.

Hi,

thank you for your reply. I got it working just now. The problem was, that in .htaccess I had some “=” instead of blanks (copy&paste-fun :-( )
Once I removed them everything worked as a charm. Thanks anyway!
Regards,
Otto