[SOLVED] Update ZCP 7.2.1-51838 to Kopano 8.6.80

Hi @ all,

My Ubuntu Server 18.04 is now running fine with Zarafa Kopano 8.6.80. I have a lot of e-mails on my old installation which is on my synology. Now I want to transfer the data to this new server.

I have read a lot about that. There are different ways.

  1. Migrate the old database to the new. Since I’m a lucky guy (once I hope) because I have Zarafa 7.2.1 unfortunately not 7.2.3 . As far I read it should be possible to migrate.

My plan is:

  1. Save the old database
  2. Move the database which is including all the attachments to the new server

Questions:

  • What else do I need to do?
  • Do I have to replace the already created database?
  • Is there no script needed?
  1. export to .pst and import in Kopano
    This works but I have on the contacts already some strange letters in it. So that’s why I want to use this as backup solution.

Does anyone found a tutorial on the web which is showing a migration step by step?

Thanks for your support - This is the last step :=)

Hi WalterHof,

I already read that twice and from there I have my plan for the migration.

For example: 4.2.8. LDAP schema I don’t use LDAP but do I need to do that as well?
Sam with this topic: 4.3.1. LDAP data transplantation to new schema ?

Hi,

if you use DB backend, continue to use DB backend.

So what I have done and tried now:

I created with sypexdumper a sql dump of my running zarafa instance on my Synology. Then I copied the file on my NAS to a location where I can access from my new server.

Importing this file doesn’t work.

The tables before lob are created and also filled.
At this stage it will exit with killed after 10 hours or so:

--------------
CREATE TABLE `lob` (
  `instanceid` int(11) unsigned NOT NULL,
  `chunkid` smallint(6) unsigned NOT NULL,
  `tag` smallint(6) unsigned NOT NULL,
  `val_binary` longblob,
  PRIMARY KEY (`instanceid`,`tag`,`chunkid`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 MAX_ROWS=1000000000 AVG_ROW_LENGTH=1750
--------------

The database is around 3 gb. What can I do now? I can try to split that file… I try now different options…
I don’t understand why this is again a huge problem in 2018. I know this is not a Kopano issue.

The problem came from a corrupted backup via Sypexdumper.

Solution:

Create a backup wie mysqldump and get a backup.sql file. For example with this command:
mysqldump -u root -p zarafa > zarafabackup.sql

Move this file to your location my location was: /home/kopano/

For import into Kopano:
mysql -u root -p
CREATE DATABASE zarafa;
exit

Now you can start the import:
mysql --verbose -u kopanosql -p zarafa < /home/kopano/zarafabackup.sql

Yes it’s possible to migrate from ZCP 7.2.1-51838 to Kopano 8.6.80 - I have done it!

Thanks you can close this thread.