gsoap tcp connect error



  • Hi guys,

    after upgrading to 8.6.80.1248 I get an error when trying to login via imap. Everything else works fine (ActiveSync, WebApp, Server).

    The log file shows the following:

     [error  ] gsoap connect: connect failed in tcp_connect()
    Sun Jul 22 17:10:45 2018: [error  ] HrLogon server "http://localhost:236/" user "******": network error
    Sun Jul 22 17:10:45 2018: [warning] Failed to login from [[::ffff:*.*.*.*]:49781] with invalid username "*****" or wrong password: network error (80040115)
    

    Can anyone help?

    Thank you



  • @yep_dd

    [error ] gsoap connect: connect failed in tcp_connect()
    Sun Jul 22 17:10:45 2018: [error ] HrLogon server “http://localhost:236/” user “******”: network error

    First try

    $ telnet localhost 236
    


  • First try

    $ telnet localhost 236
    

    connection refused? now, i am confused… server is running

    server_bind             = 127.0.0.1
    
    # Accept normal TCP connections (not recommended to disable)
    server_tcp_enabled      = yes
    
    # Port to bind to
    server_tcp_port         = 236
    
    # Accept Unix pipe connections (not recommended to disable)
    server_pipe_enabled     = yes```


  • @yep_dd

    First try

    $ telnet localhost 236

    connection refused? now, i am confused… server is running

    server_bind = 127.0.0.1
    server_tcp_enabled = yes
    server_tcp_port = 236
    server_pipe_enabled = yes```

    Old server.cfg directives. You need to use newer from /usr/share/doc/kopano/example-config/server.cfg



  • thanks that’s it… working like a charm now


Log in to reply