PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/mapi.so

After restart apache
apacher-error.log.
[Sat Jul 21 12:43:24.207795 2018] [mpm_prefork:notice] [pid 1300] AH00169: caught SIGTERM, shutting down
[Sat Jul 21 12:43:25.335415 2018] [ssl:warn] [pid 3958] AH01909: 192.168.2.243:443:0 server certificate does NOT include an ID which matches the server name
[Sat Jul 21 12:43:25.354487 2018] [ssl:warn] [pid 3959] AH01909: 192.168.2.243:443:0 server certificate does NOT include an ID which matches the server name
[Sat Jul 21 12:43:25.354609 2018] [http2:info] [pid 3959] mod_http2 (v1.0.11, nghttp2 1.7.1), initializing…
PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/mapi.so’ - /usr/lib/libkcfreebusy.so.0: version `KC_8.5.6’ not found (required by /usr/lib/php/20151012/mapi.so) in Unknown on line 0
[Sat Jul 21 12:43:25.391626 2018] [mpm_prefork:notice] [pid 3959] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Sat Jul 21 12:43:25.391679 2018] [core:notice] [pid 3959] AH00094: Command line: ‘/usr/sbin/apache2’

Did you maybe not update all of the packages?

Ps: this forum uses markdown for formatting. Please use code blocks when posting log segments, as this makes it easier to read your post.

I think we on the right way:
Paketaktualisierung (Upgrade) wird berechnet… Fertig
Die folgenden Pakete sind zurückgehalten worden:
kopano-backup kopano-client kopano-common kopano-contacts kopano-dagent kopano-gateway kopano-ical kopano-monitor kopano-presence kopano-search kopano-server kopano-server-packages kopano-spooler kopano-utils libegl1-mesa libgbm1
libgl1-mesa-dri libkcinetmapi0 libwayland-egl1-mesa libxatracker2 linux-generic-hwe-16.04 linux-headers-generic-hwe-16.04 linux-image-generic-hwe-16.04 mesa-vdpau-drivers php7-mapi python-mapi
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 26 nicht aktualisiert.
How can i use code blocks?

Thank u for the tip.
After apt-get dist-upgrade and reboot Kopano works!!!

This is a known bug in the Kopano debian packages (needing apt-get dist-upgrade). Unfortunately Kopano did not fix this bug.

@walterhof said in PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/mapi.so:

This is a known bug in the Kopano debian packages

You always needs to run apt-get dist-upgrade or apt full-upgrade if the dependencies have changed…

Felix,
I assume or hope, that packages with same version number do have the same dependencies. But Kopano Debain packages do not follow this schema.
Logs from an Update from 8.5.9.0 to 8.6.2.1:

# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  kopano-backup kopano-client kopano-common kopano-contacts kopano-dagent kopano-gateway kopano-ical kopano-monitor kopano-presence kopano-search kopano-server
  kopano-server-packages kopano-spooler kopano-utils libkcinetmapi0 php5-mapi python-mapi
The following packages will be upgraded:
  base-files file ghostscript kopano-bash-completion kopano-lang kopano-webapp kopano-webapp-plugin-desktopnotifications kopano-webapp-plugin-filepreviewer
  kopano-webapp-plugin-files kopano-webapp-plugin-filesbackend-owncloud kopano-webapp-plugin-folderwidgets kopano-webapp-plugin-gmaps kopano-webapp-plugin-mdm
  kopano-webapp-plugin-pimfolder kopano-webapp-plugin-quickitems kopano-webapp-plugin-spell kopano-webapp-plugin-spell-de-at kopano-webapp-plugin-spell-de-ch
  kopano-webapp-plugin-spell-de-de kopano-webapp-plugin-spell-en kopano-webapp-plugin-spell-en-gb kopano-webapp-plugin-spell-es kopano-webapp-plugin-spell-fr
  kopano-webapp-plugin-spell-nl kopano-webapp-plugin-spell-pl-pl kopano-webapp-plugin-titlecounter kopano-webapp-plugin-webappmanual ldap-utils lib32ncurses5 lib32tinfo5
  libgs9 libgs9-common libkcarchiver0 libkcarchivercore0 libkcfreebusy0 libkcicalmapi0 libkcmapi0 libkcserver0 libkcsoap0 libkcssl0 libkcsync0 libkcutil0 libldap-2.4-2
  libmagic1 libmapi1 libncurses5 libncursesw5 libncursesw5:i386 libpq5 libtinfo5 libtinfo5:i386 ncurses-base ncurses-bin ncurses-term patch python-kopano python-reportbug
  reportbug slapd z-push-autodiscover z-push-backend-kopano z-push-common z-push-config-apache z-push-ipc-sharedmemory z-push-kopano z-push-kopano-gabsync zsh
67 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.
Need to get 0 B/26.0 MB of archives.
After this operation, 268 kB of additional disk space will be used.
Do you want to continue? [Y/n] y

Please note the message: “The following packages have been kept back:”

A “apt-get dist-upgrade” installed this packages:

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  kopano-presence libdb5.1 python-sleekxmpp python2.6 python2.6-minimal
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
  libkcpyconv0 libkcpydirector0
The following NEW packages will be installed:
  libkcrosie0 libtidy5
The following packages will be upgraded:
  kopano-backup kopano-client kopano-common kopano-contacts kopano-dagent kopano-gateway kopano-ical kopano-monitor kopano-presence kopano-search kopano-server
  kopano-server-packages kopano-spooler kopano-utils libkcinetmapi0 php5-mapi python-mapi
17 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Need to get 0 B/2,186 kB of archives.
After this operation, 632 kB of additional disk space will be used.
Do you want to continue? [Y/n]

Question: for the packages from upgrade run how the get there dependencies solved and why the packages from dist-upgrade run do have different dependencies?

BTW you see an additional bug in this version:

The following packages were automatically installed and are no longer required:
  kopano-presence libdb5.1 python-sleekxmpp python2.6 python2.6-minimal
Use 'apt-get autoremove' to remove them.

The installer wants me to remove kopano-presence.

@walterhof said in PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/mapi.so:

packages with same version number do have the same dependencies

Logs from an Update from 8.5.9.0 to 8.6.2.1:

You have upgraded from one release (8.5.x) to another release (8.6.x) here new features and changed dependencies are expected.

@walterhof said in PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/mapi.so:

Question: for the packages from upgrade run how the get there dependencies solved and why the packages from dist-upgrade run do have different dependencies?

Packages don’t have different dependencies, when running apt-get upgrade vs. apt-get dist-upgrade. Maybe reading 8.1.2 from https://www.debian.org/doc/manuals/debian-faq/ch-pkgtools.en.html helps for a better understanding of Debian tools.

@walterhof said in PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/mapi.so:

BTW you see an additional bug in this version:

The installer wants me to remove kopano-presence.

Again: Not a bug. ´kopano-presence´ was removed from the ´kopano-server-packages´ meta package, since its not an essential component for most systems (only interesting if running kopano-webmeetings)…

Felix,
you stated: “Again: Not a bug. ´kopano-presence´ was removed from the ´kopano-server-packages´ meta package” but this was never communicated, in release notes I did not find this information and for SLES systems, the kopano-presence module is included in server meta package, it will not be removed. So the build system for kopano is not consistent and this creates a lot of troubles for an system admin like me.

I don’t understand how removing a package, that you did not use in the first place creates trouble for you. But thanks for the reminder that the package was still in the rpm packaging, will remove it there as well.

I’m closing up here now, if you still want to discuss please discuss with our support.

edit: actually I don’t see that dependency on the spec file at all

Locked