Kopano Server 8.6.2 - Received date lost on moved mails

Hi Kopano Team,
since latest upgrade I discovered that after moving mails from inbox some of them loosing their received date property. Don’t know if other props get lost too. I get everydoy some status mails from my router and repeaters (Fritz! Equipment, latest firmware) in my inbox and move them manually by sometimes by smartphone (z-push latest stable 2.4.3), sometimes by client (outlook + zarafa-client 7.2.6.50). They get moved in blocks of 3 messages and some of them in destination folder are without received date if I look at the message list in destination folder by outlook client. In server log I cannot find any entry that might be related to the date and time I’ve moved the messages.

Sorry but no further details available. If you have an idea what I should check please tell me the commands I should issue and I will provide you the results…

Best regards

Andreas

Hi @dw2412 ,

I am not able to see this behavior in a 8.6.2 test installation.

For the sake of completeness:

@dw2412 said in Kopano Server 8.6.2 - Received date lost on moved mails:

since latest upgrade

from where did you upgrade?

Hi,

I’ve seen same on 8.6.2 on UCS4.3 with last Kopano Updates - WebApp 3.4.17.1613+74.1 after deleting mals in inbox some show up in trash without received date - after selecting them (by single item) the date came back but on refresh of the folder they are gone again. (click on them brings the date back until refrsh the view

rg
Christian

@externa1 said in Kopano Server 8.6.2 - Received date lost on moved mails:

with last Kopano Updates

again: from where did you upgrade?

I just moved 200 mails in small batches from one folder to the other. every one of those mails still has its received date.

Updated through univention app-center

to see the behaviour i did a small capture here: https://remote.ckc-it.at/nextcloud/index.php/s/Nq36fscee7xQwk5

rg
Christian

@externa1 said in Kopano Server 8.6.2 - Received date lost on moved mails:

Updated through univention app-center

So from 8.4.5?

Yes from 8.4.5 Univention App Version

Only 8.4.5 univention app version or also 8.4.5 packages for the server?

I think server packages have been 8.5.x but i would have to grap from update log if this is important to you

rg
Christian

Hi @fbartels ,

well, since I’ve wrote my mail it happened but still I’m not able to reproduce and it does not happen always. Currently I’m on stable channel and update gets installed as soon as they’re available there. According the versions table I updated to 8.5.9 on 2018-05-19 and from that version to 8.6.2 on 2018-06-15 (thats for the db schema) and for packages in apt history.log it says that kopano-server-packages:amd64 (8.5.9.0-0+6.1, 8.6.2.1-0+5.1) was updated on “Start-Date: 2018-06-15 08:49:37”. This was the last update I got using apt-get dist-upgrade.

Andreas

@fbartels,
some maybe interesting update on this. Today I manually restartet the kopano-server and after kopano-server restart all the lost received dates got back. So maybe it is an issue in kopano-server regarding autocalc fields.

Andreas