Kopano Nightly Installation MAPI Error

Hi everyone,

i hope this is the right section to post my question. Currently i am using Kolab as groupware. In the last few weeks i have done a lot of research for a replacement. So i started with a test vm with Kopano.

Installed the maschine on 18.06.2018 with 8.6.80.1018-0+152.1 Kopano. Apart from a few little problems the system was working well. On the 10.07 (until now) i started a second VM with 8.6.80.1248-0+176.1 Kopano. After the installation i tried to login and got the message “Unknown MAPI Error: MAPI_E_NOT_FOUND”. I checked all logfiles and googled around. Hours laters i came to a page that indicates, that the mail store is missing. And the post was right. After creating a new user(s) the store was missing:

root@vm:~# kopano-cli --list-users
User list for Default (2):
            User           Full Name          Homeserver                                   Store
------------------------------------------------------------------------------------------------
          SYSTEM              SYSTEM             Unknown        8962FFEFFB7B4D639BC5967C4BB58234
        myuser         Dummy User             Unknown        

This does not happen on my maschine from june with the older version. So i tried to add the store by hand “kopano-admin --create-store myuser”, after that the user was able to login. Error in logs are still present.

E.g. Apache:

[Fri Jul 13 16:42:33.367210 2018] [:error] [pid 1450] [client 1.2.3.4:22153] Failed to open store with entryid 0 (Public store), referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:33.367274 2018] [:error] [pid 1450] [client 1.2.3.4:22153] MAPIException: MAPI error  in /usr/share/kopano-webapp/server/includes/core/class.mapisession.php:543\nStack trace:\n#0 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(543): mapi_openmsgstore(Resource id #3, '0')\n#1 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(504): MAPISession->openMessageStore(0, 'Public store')\n#2 /usr/share/kopano-webapp/server/includes/core/class.mapisession.php(515): MAPISession->getPublicMessageStore()\n#3 /usr/share/kopano-webapp/server/includes/core/class.operations.php(719): MAPISession->getAllMessageStores()\n#4 /usr/share/kopano-webapp/server/includes/core/class.operations.php(288): Operations->getFavoritesFolders(Resource id #43, Array)\n#5 /usr/share/kopano-webapp/server/includes/modules/class.hierarchymodule.php(456): Operations->getHierarchyList(Array)\n#6 /usr/share/kopano-webapp/server/includes/modules/class.hierarchymodule.php(85): HierarchyModule->hierarchyList()\n#7 /usr/share/kopano-webapp/server/includes/core/class.jsonrequest.php(57): HierarchyModule->execute()\n#8 /usr/share/kopano-webapp/kopano.php(139): JSONRequest->execute('{"zarafa":{"hie...')\n#9 {main}, referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:33.788980 2018] [:error] [pid 1450] [client 1.2.3.4:22153] [DBG][AccountStore] Found 0 accounts., referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:33.789037 2018] [:error] [pid 1450] [client 1.2.3.4:22153] [DBG][FilesAccountModule] Sorting by account_sequence in direction: ASC, referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:34.026272 2018] [:error] [pid 1450] [client 1.2.3.4:22153] [DBG][BackendStore] Searching for external backends in /usr/share/kopano-webapp/plugins/, referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:34.026391 2018] [:error] [pid 1450] [client 1.2.3.4:22153] [DBG][BackendStore] Registering backend: FTP, referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:34.026434 2018] [:error] [pid 1450] [client 1.2.3.4:22153] [DBG][BackendStore] Registering backend: Webdav, referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:34.026713 2018] [:error] [pid 1450] [client 1.2.3.4:22153] [DBG][BackendStore] Registering external backend: SMB, referer: https://mail.dom.tld/webapp/
[Fri Jul 13 16:42:34.026805 2018] [:error] [pid 1450] [client 1.2.3.4:22153] [DBG][BackendStore] Registering external backend: Owncloud, referer: https://mail.dom.tld/webapp/

Is this a bug in the current version? I found a similar error here => https://help.univention.com/t/ucs-4-3-0-nach-upgrade-php-mapi-extension-not-found/9090

Thanks for reading.

Hi,

that stores are not created when a user is created is indeed a know issue. It will likely be fixed in the beginning of next week.

The main (and first) error in your Apache logging is since you don’t have a public store (you always need to create it manually).

The other errors come from the files plugin. I’m not too familiar with it, but my guess is they can be ignored.

Hi,

thanks for the quick response. Good to know that the bug will be fixed soon.

I have one more question. As far as i can see, the nightly builds are the only way today to install kopano? The alternative is a subscription ? https://kopano.io/community-provided-debian-and-opensuse-packages-for-kopano/ says the Repo will be included in the next Debian Release, where are the differences? Sounds like the current “enterprise” repo will be opened on next year?

@huerter said in Kopano Nightly Installation MAPI Error:

the nightly builds are the only way today to install kopano? The alternative is a subscription

No, they are just the only binary distribution if you don’t have a subscription. The source code of all releases is still available as well…
On of the benefits if having a subscription is access to packages that have passed qa and are officially supported by use.

Others are free to take the sources and build and distribute their own packages, this is what is done in opensuse, Debian and also the latest Ubuntu lts. Depending on packaging policies of the distribution the provided release may be older, than what is accessible from us.