Kopano Spooler doesn't bind to socket

Hi,

I found out that I have to configure spooler.cfg (nano /etc/kopano/spooler.cfg) to use postfix for sending out e-mails.
I have a problem with the spooler it won’t start.

Tue Jun 19 16:24:39 2018: [info   ] [14058] Logger process started on pid 14060
Tue Jun 19 16:24:39 2018: [debug  ] [14058] StatsClient binding socket
Tue Jun 19 16:24:39 2018: [debug  ] [14058] StatsClient bound socket to /tmp/.6da316e119f135e2.sock
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Submit thread started
Tue Jun 19 16:24:39 2018: [debug  ] [14058] StatsClient thread started
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Initializing provider "Kopano Directory Service"
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Initializing provider "Private Folders"
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Initializing provider "Public Folders"
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Initializing provider "Kopano Directory Service"
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Initializing provider "Private Folders"
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Initializing provider "Public Folders"
Tue Jun 19 16:24:39 2018: [debug  ] [14058] PYTHONPATH = /usr/share/kopano-spooler/python
Tue Jun 19 16:24:39 2018: [info   ] [14058] * Loading plugins started
Tue Jun 19 16:24:39 2018: [info   ] [14058] ** Checking plugins in /var/lib/kopano/spooler/plugins
Tue Jun 19 16:24:39 2018: [info   ] [14058] * Loading plugins done
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Sending e-mail for user KOPANOUSER, subject: "TEST", size: 1898
Tue Jun 19 16:24:39 2018: [info   ] [14058] * PreSending processing started
Tue Jun 19 16:24:39 2018: [info   ] [14058] * PreSending processing done
Tue Jun 19 16:24:39 2018: [debug  ] [14058] Sending message with Message-ID: kcis.6E3B37A396A54568ADDB310F7EA3232D@svgwma-kopa-02.XXXXX.XXXX.com
Tue Jun 19 16:24:39 2018: [debug  ] [14058] RCPT TO: marcXXXXXx@hotmail.com
Tue Jun 19 16:24:39 2018: [debug  ] [14058] SMTP connecting to localhost:25
Tue Jun 19 16:24:39 2018: [error  ] [14058] Connect to SMTP: Error while connecting socket.. E-Mail will be tried again later.
Tue Jun 19 16:24:39 2018: [debug  ] [14058] < QUIT
Tue Jun 19 16:24:39 2018: [warning] [14058] Unable to connect to SMTP server, retrying mail for user kreativinfo later
Tue Jun 19 16:24:39 2018: [info   ] [14060] Log process is done

Here is my configuration:

##############################################################
# SPOOLER SETTINGS

# Outgoing mailserver name or IP address
smtp_server = localhost

# Port number for outgoing mailserver
smtp_port = 25

# Server Unix socket location
server_socket = file:///var/run/kopano

# drop privileges and run the process as this user
run_as_user =

# drop privileges and run the process as this group
run_as_group =

# create a pid file for stopping the service via the init.d scripts
pid_file = /var/run/kopano/spooler.pid

# run server in this path (when not using the -F switch)
running_path = /var/lib/kopano

# create memory coredumps upon crash [no, systemdefault, yes]
coredump_enabled = no

# for temporary files
# consider mounting a `tmpfs' underneath this path (wherever you
# point it to)
tmp_path = /tmp

##############################################################
# SPOOLER LOG SETTINGS

# Logging method (syslog, file)
log_method = file

# Loglevel (0(none), 1(crit), 2(err), 3(warn), 4(notice), 5(info), 6(debug))
log_level = 6

# Logfile for log_method = file, use '-' for stderr
log_file = /var/log/kopano/spooler.log

# Log timestamp - prefix each log line with timestamp in 'file' logging mode
log_timestamp = yes

# Buffer logging in what sized blocks. 0 for line-buffered (syslog-style).
log_buffer_size = 4096

# Dump raw messages into specified directory before sending to smtpd.
# log_raw_message_path = /tmp
# log_raw_message_stage1 = no

##############################################################
# SPOOLER SSL LOGIN SETTINGS
#
# Note: server_socket must be set to https://servername:portname/
#       to use this type of login method

# Login to the storage server using this SSL Key
#sslkey_file = /etc/kopano/ssl/spooler.pem

# The password of the SSL Key
#sslkey_pass = replace-with-server-cert-password
##############################################################
# SPOOLER THREAD SETTINGS

# Maximum number of threads used to send outgoing messages
max_threads = 5

##############################################################
# SPOOLER FAXING SETTINGS

# When sending an email that must go to a fax address, the address
# will be rewritten to <phonenumber>@<fax_domain>
# fax_domain =

# If the received number starts with a '+', it will be replaced by
# the fax_international value.
# e.g. +3112345678@fax.local will be rewritten to 003112345678@fax.local
# fax_international = +

##############################################################
# SPOOLER DELEGATE SETTINGS

# Set this value to 'yes' to let the spooler always send emails with
# delegates (other user than yourself in the From: header)
# In installations before 6.20, this value was always 'yes'.
# IMPORTANT: This feature overrides "send-as" functionality.
# always_send_delegates = yes

# Set this value to 'no' if you do NOT want to allow redirected e-mails
# being sent with their original 'FROM' header
allow_redirect_spoofing = yes

# Copies the sent mail of delegates and send-as mails in the
# "Sent Items" folder of the representer.
copy_delegate_mails = yes

# Allow to forward and sent a meeting request as delegate Kopano and
# SMTP user.
allow_delegate_meeting_request = yes
# Allow users to send email to the 'everyone' group
allow_send_to_everyone = yes

##############################################################
# SPOOLER OUTPUT SETTINGS

# Set this value to 'yes' to always send meeting request information
#   using TNEF method (winmail.dat attachments).
#   Otherwise, the meeting request information is sent using
#   iCalendar (calendar.ics attachment).
# Mail bodies created in RTF text format will also use TNEF.
always_send_tnef = no

# The us-ascii charset will be upgraded to this charset, to allow more
# use of high-characters.
charset_upgrade = windows-1252

# Request SMTP Delivery Status Notifications if the MTA support it
enable_dsn = yes

##############################################################
# SPOOLER GROUP EXPANSION

# Set this value to 'yes' if groups should be expanded to their
# members; This means that the receiving party will see the names
# of the group members in the To: header for example. If set to
# 'no', the name of the group will appear in the headers.
#
# Note: groups with email addresses are never expanded
expand_groups = no

##############################################################
# SPOOLER ARCHIVING SETTINGS

# Enable archive_on_send to automatically archive all outgoing
# messages.
# This will do nothing if no archive is attached to the source mailbox.
archive_on_send = no

##############################################################
# SPOOLER PLUGIN SETTINGS

# Enable the spooler plugin framework
plugin_enabled = yes

# Path to the spooler plugin manager
plugin_manager_path = /usr/share/kopano-spooler/python

# Path to the activated spooler plugins.
#   This folder contains symlinks to the kopano plugins and custom scripts. The plugins are
#   installed in '/usr/share/kopano-spooler/python/plugins/'. To activate a plugin create a symbolic
#   link in the 'plugin_path' directory.
#
# Example:
#  $ ln -s /usr/share/kopano-spooler/python/plugins/disclaimer.py /var/lib/kopano/spooler/plugins/disclaimer.py
plugin_path = /var/lib/kopano/spooler/plugins

Any help is appreciated :=). I’m still working on sending e-mails via postfix…

hi,
which smtp server do you use? Postfix oder exim ?
Properbly these are blocking port 25
netstat -an|grep LISTEN |grep 25 gives more infos

It’s neither that spooler doesn’t bind to a socket, or won’t start. It’s not able to connect to your local SMTP.

Hi @AnotherAndy and @fbartels

I found the problem in the master configuration.

The line smtp has to be alligned correctly so that everything in the same “row”. This was not the case and it lead to this problem. Yes postfix was not listening at port 25 because of that.

# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (no)    (never) (100)
# ==========================================================================
smtp       inet  n       -       y       -       -       smtpd
#smtp      inet  n       -       y       -       1       postscreen
#smtpd     pass  -       -       y       -       -       smtpd
#dnsblog   unix  -       -       y       -       0       dnsblog
#tlsproxy  unix  -       -       y       -       0       tlsproxy
#submission inet n       -       y       -       -       smtpd

This thread can be closed and is fixed.

Locked