core-8.6.80.1005_0+148-Debian_9.0-amd64

Hej!

Trying fresh new installation with core-8.6.80.1005_0+148-Debian_9.0-amd64.

Path:

Install with:

dpkg -i *.deb

and

apt -f install

Installation bring up errors with dependencies with module

Unpacking libjansson-dev:amd64 (2.7-1) over (2.7-1) ...
dpkg: warning: downgrading libjansson-doc from 2.9-1 to 2.7-1

And there are no config-files created in path:

/etc/default

…and

/etc/kopano

Only

root@kc1:/etc/kopano# ll
total 8
drwxr-xr-x 2 root root 4096 Jun 12 13:38 quotamail
drwxr-xr-x 8 root root 4096 Jun 12 13:38 userscripts

…are there.

Regards
Marcus

Hi @marcus-bauch ,

the not installed files were previously discussed in https://forum.kopano.io/topic/1448/no-config-files-created-during-install

At the moment it’s expected that these files are not installed. We are currently discussing how to improve the general first usage experience.

As for the installation with dpkg -i *.deb not all packages are really needed to run. Please consult the manual and our knowledge base for better ways.

@fbartels

Hello Felix,
yes, i see.

But there more failures during installtion.

It is okay (for me) to copy the config-files from /usr/share/doc/kopano/example-config, but the /etc/default/kopano is named sysconfig.txt.

If this all is done, and the kopano.cfg is modified kopano-server will start, but…

…if i create a user (e.g. Admin) with

kopano-cli --create --user Admin --password pass --email admin@12345.de --fullname Administrator --admin-level 1

…followed by

kopano-cli --list-users

…bring up the error

User list for Default (2):
            User           Full Name          Homeserver                                   Store
------------------------------------------------------------------------------------------------
'ascii' codec can't decode byte 0xc3 in position 9: ordinal not in range(128)

…kopano-admin work!

root@kc1:~/core-8.6.80.1005_0+148-Debian_9.0-amd64# kopano-admin -l
User list for Default(2):
        Username        Fullname        Homeserver
        ------------------------------------------------------
        SYSTEM          SYSTEM          Server
        Admin           Administrator

If i want to delete the user…

#kopano-cli --delete admin
extra argument 'admin' specified

…does not work…

# kopano-admin -d admin
User deleted.

…work.

Using commands decribed at https://documentation.kopano.io/kopanocore_administrator_manual/user_management.html

There is another dependency problem within the installtion.

E.g. if apache is installed, but php(7) not, core-installation does not install php7-mapi_8.6.80.1005-0+148.1_amd64.deb.
And/or core does not install php(7).

WebApp (webapp-3.4.16.1549+884-Debian_9.0-all.tar.gz):

There are “double” files with different version-names in the package (spellcheck):

-rw-r--r-- 1 25122 users 4901968 Jun 11 10:29 kopano-webapp_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   21202 Jun 11 10:28 kopano-webapp-plugin-contactfax_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   21194 Apr 30 10:41 kopano-webapp-plugin-desktopnotifications_2.0.1.0+13.9_all.deb
-rw-r--r-- 1 25122 users 2214644 Apr 30 10:34 kopano-webapp-plugin-filepreviewer_2.0.0.15+10.3_all.deb
-rw-r--r-- 1 25122 users   29010 Jun 11 10:28 kopano-webapp-plugin-folderwidgets_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   21874 Jun 11 10:28 kopano-webapp-plugin-gmaps_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   11360 Apr 30 10:30 kopano-webapp-plugin-intranet_0.1+32.3_all.deb
-rw-r--r-- 1 25122 users   13782 Apr 30 10:50 kopano-webapp-plugin-mattermost_0.1+14.4_all.deb
-rw-r--r-- 1 25122 users   19044 Jun 11 10:28 kopano-webapp-plugin-pimfolder_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   42926 Jun 11 10:28 kopano-webapp-plugin-quickitems_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   25488 May  8 15:30 kopano-webapp-plugin-spell_2.0.0.4+12.1_all.deb
-rw-r--r-- 1 25122 users   25494 May  8 15:30 kopano-webapp-plugin-spell_2.0.0.4+13.1_all.deb
-rw-r--r-- 1 25122 users  883182 May  8 15:41 kopano-webapp-plugin-spell-de-at_2.0.0.2+15.1_all.deb
-rw-r--r-- 1 25122 users  883140 May  8 15:32 kopano-webapp-plugin-spell-de-at_2.0.0.2+8.1_all.deb
-rw-r--r-- 1 25122 users  882256 May 16 15:29 kopano-webapp-plugin-spell-de-ch_2.0.0.3+16.1_all.deb
-rw-r--r-- 1 25122 users  280580 May  8 15:30 kopano-webapp-plugin-spell-de-de_2.0.0.1+7.1_all.deb
-rw-r--r-- 1 25122 users  280580 May  8 15:30 kopano-webapp-plugin-spell-de-de_2.0.0.1+8.1_all.deb
-rw-r--r-- 1 25122 users  177300 May  8 15:34 kopano-webapp-plugin-spell-en_2.0.0.1+10.1_all.deb
-rw-r--r-- 1 25122 users  177302 May  8 15:44 kopano-webapp-plugin-spell-en_2.0.0.1+16.1_all.deb
-rw-r--r-- 1 25122 users  225092 May  8 15:46 kopano-webapp-plugin-spell-en-gb_2.0.0.1+15.1_all.deb
-rw-r--r-- 1 25122 users  266746 May  8 15:48 kopano-webapp-plugin-spell-es_2.0.0.1+15.1_all.deb
-rw-r--r-- 1 25122 users  266830 May  8 15:35 kopano-webapp-plugin-spell-es_2.0.0.1+9.1_all.deb
-rw-r--r-- 1 25122 users  308442 May  8 15:43 kopano-webapp-plugin-spell-fr_2.0.0.1+16.1_all.deb
-rw-r--r-- 1 25122 users  311782 May  8 15:51 kopano-webapp-plugin-spell-it_1.0.0+28.1_all.deb
-rw-r--r-- 1 25122 users  533832 May  8 15:40 kopano-webapp-plugin-spell-nl_2.0.0.1+15.1_all.deb
-rw-r--r-- 1 25122 users  534032 May  8 15:50 kopano-webapp-plugin-spell-nl_2.0.0.1+17.1_all.deb
-rw-r--r-- 1 25122 users  937632 Apr 30 11:10 kopano-webapp-plugin-spell-pl-pl_2.0.0.0+10.10_all.deb
-rw-r--r-- 1 25122 users   15172 Jun 11 10:28 kopano-webapp-plugin-titlecounter_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   15462 Jun 11 10:28 kopano-webapp-plugin-webappmanual_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   16408 Jun 11 10:28 kopano-webapp-plugin-zdeveloper_3.4.16.1549+884.1_all.deb
-rw-r--r-- 1 25122 users   10576 Apr 30 11:12 whatsapp4deskapp_0.1+4.13_all.deb

YES! I can remove the files, but some users may run into a headache ;o)

I know this is “beta-software”, but i think you need to know those problems, or not?

Kind regards
Marcus

@marcus-bauch said in core-8.6.80.1005_0+148-Debian_9.0-amd64:

If i want to delete the user…
#kopano-cli --delete admin
extra argument ‘admin’ specified

…does not work…

ah, that was actually a mistake in the documentation. for the command to work the --user (or short -u) parameter needs to be passed as well.

@marcus-bauch said in core-8.6.80.1005_0+148-Debian_9.0-amd64:

E.g. if apache is installed, but php(7) not, core-installation does not install php7-mapi_8.6.80.1005-0+148.1_amd64.deb.
And/or core does not install php(7).

do you get an error when trying to install php7-mapi?

@marcus-bauch said in core-8.6.80.1005_0+148-Debian_9.0-amd64:

There are “double” files with different version-names in the package (spellcheck):

that seems to have fixed itself by now.

@marcus-bauch

Trying fresh new installation with core-8.6.80.1005_0+148-Debian_9.0-amd64.

One question: Is that a really fresh installation or does the Mysql database contain data from an old installation?

It is okay (for me) to copy the config-files from /usr/share/doc/kopano/example-config, but the /etc/default/kopano is named sysconfig.txt.

Unless you absolutely have to change something, no. And then, just writing down the lines rather than copying the entire file means there is less clutter in the file.

…bring up the error

User list for Default (2):
            User           Full Name          Homeserver                                   Store
------------------------------------------------------------------------------------------------
'ascii' codec can't decode byte 0xc3 in position 9: ordinal not in range(128)

…kopano-admin work!

root@kc1:~/core-8.6.80.1005_0+148-Debian_9.0-amd64# kopano-admin -l
User list for Default(2):
        Username        Fullname        Homeserver
        ------------------------------------------------------
        SYSTEM          SYSTEM          Server
        Admin           Administrator

If i want to delete the user…

#kopano-cli --delete admin
extra argument 'admin' specified

…does not work…

# kopano-admin -d admin
User deleted.

Just use kopano-admin.

@fbartels

I have a theory why I have that MAPI_E_LOGON_FAILED problem and @marcus-bauch doesn’t
With an existing database no probem (no confirmatio received from @marcus-bauch )
But in a new install a starting kopano-server creates database kopano, tables and populate the tables.
https://forum.kopano.io/topic/1522/db-backend-kopano-cli-mapi-error-80040111-mapi_e_logon_failed/6
If something missing in those MySQL statements can explain my problems.
Has that been/can that be tested?

@tjoen I’m not sure that a missuing reply from someone within 10 hours by someone not online for twelve days can be seen as a confirmation.

We do daily deploys of master builds internally and these have not been failing to run. On the other hand you have been deaf to my suggestions to try to replicate your problem with our packages (on one of our officially supported distributions and not on e.g. a mixture of different fedora releases).

@fbartels

@tjoen I’m not sure that a missing reply from someone within 10 hours by someone not online for twelve days can be seen as a confirmation.

But I wrote

no confirmation received

@fbartels

On the other hand you have been deaf to my suggestions to try to replicate your problem with our packages (on one of our officially supported distributions and not on e.g. a mixture of different fedora releases).

I reported the same problem with Fedora Rawhide package. Dependencies for other packages are too old for my system. For Rawhide I only needed to upgrade icu and to replace my vanilla gsoap by a gsoap patched to enable shared libs.

My own purpose is not for getting Kopano working on a random system, but on my system

You could then still set it up through containerisation or virtualisation if you run a distribution that is otherwise not supported by Kopano.

@fbartels

You could then still set it up through containerisation or virtualisation if you run a distribution that is otherwise not supported by Kopano.

Getting Openstack working is in my next todo list

Hello.

Sorry for the delay…
The Resolution about kopano-cli was a Servername configured in server.cfg with German-Umlauts äöü a.s.o.

# Name for identifying the server in a multi-server environment
# server_name = Ätschibätsch ###does not work

But only kopano-cli bring up this error. I havn’t tested this with newer versions.